-   Fedora (
-   -   How to... Connect drives on USB, USB2 Port (

the_rhino 02-06-2005 01:59 PM

How to... Connect drives on USB, USB2 Port
How does one get a drive or other device (excluding mice - they seem to work fine) to be accessable to the OS when it is connected by a USB or USB2 port?

A friend is trying to use a USB2 Western Digital hard drive, a USB2 Sony 2X speed floppy drive, a USB2 CardScan 600c business card scanner and a USB2 multi-functional HP printer.

Fedora Core 2 does not see any of them.

Brian1 02-06-2005 02:04 PM

Run the app ' usbview ' and see if it shows the devices. and we will go from there.

" Google the Linux way @ "

the_rhino 02-08-2005 12:35 AM

usbview shows it.

I ran

mount -t vfat /dev/sde /mnt/wd160

and just for kicks... I ran

mount -t ntfs /dev/sde /mnt/wd160

mount -t msdos /dev/sde /mnt/wd160

mount -t ext3 /dev/sde /mnt/wd160

I keep getting errors that say it can't mount the drive because of some kind of fs errors like it does not understand or can't read the fs or there are bad blocks or to many mounted devices.

This drive is a FAT32 format and was used on a win xp pro OS. The drive is a Western Digital 160 GB USB2 external drive with 1.5 GB of data on it. The data is too important to just wipe out by trying to format the drive to work with Linux.

Any one have any ideas what else I can try?

Any help is always appreciated.

All times are GMT -5. The time now is 03:18 AM.