LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Fedora (https://www.linuxquestions.org/questions/fedora-35/)
-   -   How to automount windows drives in FC6? (https://www.linuxquestions.org/questions/fedora-35/how-to-automount-windows-drives-in-fc6-503721/)

S_VIN 11-21-2006 06:05 PM

How to automount windows drives in FC6?
 
Hi all,
I have installed FC6 in my PC along with winxp. I want to share my windows drives. The drives are D drive(hda5) and E drive(hda6).

It works fine if I try the regular mount command as:
Code:

mkdir /mnt/WinXP_D
mount -t vfat /dev/hda5 /mnt/WinXP_D

..and similar code for WinXP_E with hda6

But as you would all agree to mount this way each time you login is a pain in the ass. So I tried automounting by editing the /etc/fstab as:
Code:

/mnt/WinXP_D /dev/hda5 vfat rw,auto,user,sync 0 0
/mnt/WinXP_E /dev/hda6 vfat rw,auto,user,sync 0 0

But its giving error msgs as WinXP_D(and E) is not a block device,.. is write-protected,..cannot mount... in the second line trying to mount as read-only and then cannot mount as read-only also. I could not write down the exact sentences as the screen changes very fast.

What could be wrong? I had tried similar thing in RH8 and it had worked?

Kindly guide.

David the H. 11-21-2006 06:33 PM

Change the auto line to noauto, then fstab will not attempt to mount it automatically at boot. That way you can try doing it manually from a terminal and you can see the output messages. When there's an entry in fstab, mounting is as simple as typing 'mount /dev/hd5' or 'mount /mnt/WinXP_D'. Once you've diagnosed the problem you can put it back.

(Edit after reading again) D'oh! I just noticed your problem. You have the device and mount point options reversed. /dev/hda5 should come first.

Finally, FAT drives usually should have a few extra options such as umask for setting the permissions level and uid/gid for setting the user and group. Read the vfat section in 'man mount' for more, and/or do a search of the site.

Hitboxx 11-21-2006 06:58 PM

It should read
Code:

/dev/hda5 /mnt/WinXP_D vfat rw,auto,user,umask=0000,sync 0 0
/dev/hda6 /mnt/WinXP_E vfat rw,auto,user,umask=0000,sync 0 0


S_VIN 11-24-2006 05:13 AM

Thanks David and Shrikant. I implemented your suggestion. The problem is solved.
Thanks again.


All times are GMT -5. The time now is 01:47 PM.