LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices


Reply
  Search this Thread
Old 09-28-2004, 12:29 AM   #1
Schmurff
Member
 
Registered: Mar 2004
Location: Netherland
Distribution: Fedora Core 2, Mandrake10.0
Posts: 62

Rep: Reputation: 15
Unhappy How must I edit a Makefile for another compiler???


This is my second day that I work with Fedora Core 2.
Very well. I have installed a c-compiler, not the wellknown gcc but gcc34.
Then I have this program.
According to the README the first two lines of the Makefile must be edited before I can compile the program. These are the lines:

CC=gcc
OPT_FLAGS = -O2 -Wall

The first line is obvious, it should look like this: CC=gcc34
But what must I do with the second line?
This is the first time that I must edit in a makefile, I am still a newbie.
Thanks in advance for your advices.

Schmurff
 
Old 09-28-2004, 01:22 AM   #2
CroMagnon
Member
 
Registered: Sep 2004
Location: New Zealand
Distribution: Debian
Posts: 900

Rep: Reputation: 33
I assume this gcc34 is just a newer version of gcc, so it probably still uses many of the same options. You can probably compile just fine with the second line as-is (these might need to be changed if you were using, for example, a vendor's proprietary compiler that used different options).
 
Old 09-28-2004, 03:53 AM   #3
Schmurff
Member
 
Registered: Mar 2004
Location: Netherland
Distribution: Fedora Core 2, Mandrake10.0
Posts: 62

Original Poster
Rep: Reputation: 15
I have tested it after editing the first line only to CC=gcc34. The compiler stopped:

# make
Makefile:18: *** missing separator. Stop.

After that I posted my question
 
Old 09-28-2004, 04:16 AM   #4
CroMagnon
Member
 
Registered: Sep 2004
Location: New Zealand
Distribution: Debian
Posts: 900

Rep: Reputation: 33
It is good to explain these things beforehand

I think your text editor has changed the tab characters to spaces when you saved your changes.
If you used vi/vim, load up the original Makefile again and before you save the file, use
:set noexpandtab
if you used another editor, you might need to find out what the right option is. or try a different editor.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
checking for C compiler default output... configure: error: C compiler cannot create fiorejm Linux - Software 6 11-12-2009 01:35 PM
How to modify makefile.in or makefile.am QiangWan Linux - Newbie 1 05-17-2005 12:07 PM
how to get (makefile -f makefile )output into the textview widget in Pygtk sailu_mvn Programming 3 02-28-2005 04:57 AM
generate Makefile from Makefile.in without calling ./configure ? chris78 Programming 2 05-02-2004 01:23 PM
How to edit HPL's Makefile---OSCAR, HPC srkl Linux - General 0 04-04-2004 11:37 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora

All times are GMT -5. The time now is 10:04 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration