LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices


Reply
  Search this Thread
Old 10-23-2004, 12:12 AM   #1
babyboss
Member
 
Registered: Sep 2004
Posts: 124

Rep: Reputation: 15
How do I change screen resolution for Fedora core2's shell?


I got Red Hat Fedora Linux 2. I want to install anything relate to textmode, which means I don't want to install anything relate to GUI because my CPU is a not fast enough to run GNOME and KDE. I don't like my current screen resolution under shell. It's a bit too big. Is there a way I can change it?
 
Old 10-23-2004, 02:11 AM   #2
Samsara
Member
 
Registered: May 2003
Distribution: Ubuntu, Mac OS X Tiger
Posts: 481

Rep: Reputation: 32
It's a kernel parameter. Try putting "vga=ask", reboot and see what works for you. You can also give an exact value depending on your configuration, e.g. vga=791 for millions of colours at 1024x768 resolution.

Regards,

Samsara

PS: This has a table giving the codes for various settings:
http://www.tldp.org/HOWTO/Framebuffer-HOWTO-5.html
You can also directly specify the resolution, like so:
"resolution=800x600"

Last edited by Samsara; 10-23-2004 at 02:36 AM.
 
Old 10-23-2004, 03:15 PM   #3
babyboss
Member
 
Registered: Sep 2004
Posts: 124

Original Poster
Rep: Reputation: 15
How do I do it from the beginning? where would i input this vga=ask
 
Old 10-23-2004, 03:31 PM   #4
babyboss
Member
 
Registered: Sep 2004
Posts: 124

Original Poster
Rep: Reputation: 15
I use grub to load my box. What exactly I can do to change the resolution
under console?
 
Old 10-26-2004, 06:32 PM   #5
marghorp
Senior Member
 
Registered: Jan 2004
Location: Slovenia
Distribution: Slackware 10.1, SLAX to the MAX :)
Posts: 1,040

Rep: Reputation: 45
Console resolution from grub

Hi!

The easiest way to do it from grub is this. Once in the grub OS selection menu. Press the key that is assigned to the add parameters to kernel. I think it's the 'a' key. But you better check. If you have grub password protected, first press p to input password and then follow the previous instruction. You will get the complete line with which grub starts the kernel. It will look something like kernel /vmlinuz-blablabla

After that line, insert a blank space " " and this is where you put in the vga=791 parameter
To make it permanent edit the grub.conf file under /boot/grub/ directory. Locate the kernel line and add the parameter in grub.conf. Hope I've helped you.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora Core 2: Screen Resolution can not change from "800X600" to "1024X 768" suhaimi_sj Fedora - Installation 18 12-17-2009 03:29 AM
Cannot change screen resolution HiOctane21 Linux - General 10 05-23-2005 01:37 AM
How to Change Screen Resolution eats85 Slackware 4 10-05-2003 04:06 PM
How to change screen resolution mahsan Linux - Software 4 09-30-2003 02:56 PM
Change screen resolution glock19 Linux - General 11 01-16-2002 09:10 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora

All times are GMT -5. The time now is 12:08 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration