LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Fedora (https://www.linuxquestions.org/questions/fedora-35/)
-   -   how do i (https://www.linuxquestions.org/questions/fedora-35/how-do-i-341988/)

alrave 07-10-2005 07:35 PM

how do i
 
I used to have Suse installed in my pc, but i moved to Fedora because i was having trouble with my video card.
Now the video card works fine, but the thing is that i have my HD partitioned in tree parts. One for windows, one for Fedora and one for Media Files, now i cant access the media files partition from fedora. Id like to know how to do that...
Thxs

justin_p 07-10-2005 08:53 PM

Try posting your /etc/fstab first so we have some idea for your device setup and permissions.

tommyr1216 07-11-2005 10:24 AM

You must simply configure your system to mount this partition by editing /etc/fstab. First, run the command "fdisk -l" (that's an L), which will list the partitions on your disks. Look at this output and determine which is your media partition, for example, /dev/hda4. If you are having trouble, look at the values under the System column. I'm assuming your media is a windows partition, so it will likely say HPFS/NTFS. Now open /etc/fstab in your favorite editor and add the following line:

/dev/hda4 /mnt/windows ntfs defaults 0 0

where:
/dev/hda4 is the name of your partition, you should change this to whatever you determined was your media partition using fdisk -l

/mnt/windows is the location at which you'd like this filesystem to be available. Note that you must create this mountpoint, so, if you are using /mnt/windows, you must do a "mkdir /mnt/windows" before you can mount your partition there

ntfs is your filesystem type. Since you are using XP, this will probably be NTFS. If you are using the FAT32 filesystem, use vfat here instead.

defaults is the options with which the filesystem is mounted. You can put various options here, such as noauto (don't mount automatically at boot), umask (default file permissions), etc.

0 0 tell the operating system when the partition should be checked, these are not necessary for NTFS so we use zeros.

Once you have completed your /etc/fstab and created the necessary mountpoint, you can say "mount /mnt/windows" or whatever your mountpoint was, and you should be able to access your media partition there. Since it is in your fstab file, it will automatically be mounted there each time you reboot.

FrayAdjacent 07-11-2005 01:28 PM

Wouldn't he run into a problem if the partition was NTFS? Fedora doesn't natively support NTFS. I know there are some packages to read NTFS partitions available.

If it's FAT, he should be good to go.

alrave 07-12-2005 10:06 PM

first of all, thanks for your help.
i followed tommyr1216 and did everything in his post, but im still unable to see my media partition...
ill post my fstab...
# This file is edited by fstab-sync - see 'man fstab-sync' for details
LABEL=/ / ext3 defaults 1 1
/dev/devpts /dev/pts devpts gid=5,mode=620 0 0
/dev/shm /dev/shm tmpfs defaults 0 0
/dev/proc /proc proc defaults 0 0
/dev/sys /sys sysfs defaults 0 0
LABEL=SWAP-hda1 swap swap defaults 0 0
/dev/hda5 /mnt/windows ntfs defaults 0 0
/dev/fd0 /media/floppy auto pamconsole,exec,noauto,managed 0 0
/dev/hdc /media/cdrecorder auto pamconsole,exec,noauto,managed 0 0
/dev/hdb /media/cdrecorder1 auto pamconsole,exec,noauto,managed 0 0

i dont find the files, i searched in mnt/windows and it was empty, and i tried to open dev/hda5 (thats how i used those files when i used suse) and it keeps asking me wich program do i want to use to see the files, and no matter the program i choose it keeps asking me...
any help here would be aprreciated...


All times are GMT -5. The time now is 06:39 PM.