-   Fedora (
-   -   Hmmm, where did i go wrong ? (

Reefcrazed 09-03-2004 08:24 PM

Hmmm, where did i go wrong ?
Ok i think what i did is probably a simple fix with a little guiding to get me straightened out. Ok i did another FC2 fresh install, getting good at that. I decided instead of downloading a new kernel i was just going to do it with my little flashing icon, UP2DATE. Ok everything seemed to go well, wow what a new kernel version !. Well i am a tweaker and afer updating a kernel i like to go in and trim out the fat, get it nice and small. Normally i have no problem, but where is the source to this thing ??? Ok next step was to go download the kernel, which was like something or another and unzip it into /usr/src then make my link. I then did all of the normal

make xconfig
make bzImage
make modules
make modules_install
make install

Well after this reading my old instructions the /boot files looked odd, is that because they were done with Up2date ?? My grub looked like this after all was said and done.

# grub.conf generated by anaconda
# Note that you do not have to rerun grub after making changes to this file
# NOTICE: You have a /boot partition. This means that
# all kernel and initrd paths are relative to /boot/, eg.
# root (hd0,0)
# kernel /vmlinuz-version ro root=/dev/hda2
# initrd /initrd-version.img
title Fedora Core (
root (hd0,0)
kernel /vmlinuz- ro root=LABEL=/ rhgb quiet
initrd /initrd-
title Fedora Core (2.6.8-1.521)
root (hd0,0)
kernel /vmlinuz-2.6.8-1.521 ro root=LABEL=/ rhgb quiet
initrd /initrd-2.6.8-1.521.img
title Fedora Core (2.6.5-1.358)
root (hd0,0)
kernel /vmlinuz-2.6.5-1.358 ro root=LABEL=/ rhgb quiet
initrd /initrd-2.6.5-1.358.img

Ok the problem is the one marked 2.6.8-1.521 is the one i am on now, the gives me a kernel panic VFS something or another error right after boot. I could care which one works as long as i can do my tweaking, i am a tweak junkie.

redjokerx 09-03-2004 08:53 PM

I don't usually do make install, I just copy bzImage to /boot/. Last time I remember doing a make install I ended up with LILO. Anyway, at least you're booting into grub right?

Anyway, try this for your grub entry:

title Fedora Core (
root (hd0,0)
kernel /vmlinuz- root=/dev/hdxx

where hdxx is the partition your kernel is on.

cincindie 09-04-2004 01:38 PM

I remember having the same problem after tweaking. Turned out that I had to turn on RAM disk support for initrd (it is off by default in 2.6.8.x and later versions of the kernels).

All times are GMT -5. The time now is 01:21 PM.