LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices


Reply
  Search this Thread
Old 08-05-2008, 11:05 PM   #1
maestro52
Member
 
Registered: Aug 2003
Location: Texas
Distribution: Fedora 9
Posts: 177

Rep: Reputation: 30
Question Help with dtvscan, channels.conf and mythtv setup?


I am totally confused! Not being a programmer is definitely a handicap, but I follow instructions very well.

In any case, I have recently bought the pcHDTV 5500 card with the with the HD5500 driver and all. I also have a Geforce 8500 dvi video card and a Samsung digital LCD monitor. I am running FC9 on a Phenom tricore mb with 3+ GHZ and 2gb of ddr2.

While the company I bought the tv card from sugests using mythtv for the card they only give instructions for tvtime, xawtv, and xine. Tvtime works beautifully without me having to do anything, but I am not sure it works for HD tv. The pcHDTV people had actually only mentioned tvtime for analog. Of course, I am not receiving true HD because I am on Mexican cable that is totally analog. However, I am preparing to talk to the cable people about getting the digital signal because they had mentioned it's availability at some point, otherwise I will either switch to the DISH network or buy an antenna.

All of which, I think, means I need mythtv or xine. SO, I am left with a couple major problems.

I have everything mythtv and xine related directly from FC9. When I open xine, I am told there is no channels.conf. I pause, read the pcHDTV included instructions and run,
"dtvscan -fx -o /home/gary/.xine/channels.atsc". It runs and is seeing all my channels but ends with, "Tuning Frontend: Invalid argument. It then gives me a channels.atsc folder with nothing in it. SO I run it again, this time using channels.ntsc and it creates the ntsc file with nothing in it, and then I do it with just channels.conf and it does the exact same thing.

As such, no xine for tv! I do not know what the problem is does anyone?


Now the mythtv.

I open mythtv setup and I am immediately told "No UPnP backends found". I certainly have no idea what it is talking about and move on to the next page. That page is listed as Database Configuration page 2. First, I have no idea of what to do with a database. Second, the page asks me for the HOSTNAME. I check my computer (only have one) but the network server says I am listed as localhost.localdomain. According to the set up page I do not need to do anything else. SO I ignore the automatically input info and attempt to finish. However, the next page tells me, "Cannot login to database?" I have no idea of why that occurred and certainly see no logic in the question mark when I cannot really answer the question. but as soon as I click the OK button which is all I have available to me, it automatically goes back to the setup page.

I have no more idea of what I am doing in mythtv than what is wrong with failing to create the channels.conf for xine.

Can anyone help me? PLEASE?
 
Old 08-06-2008, 06:02 PM   #2
{BBI}Nexus{BBI}
Senior Member
 
Registered: Jan 2005
Location: Nottingham, UK
Distribution: Mageia 5, Linux Lite
Posts: 4,312

Rep: Reputation: 210Reputation: 210Reputation: 210
Here's a nice simple howto on setting up Mythtv: http://linux-blog.org/index.php?/arc...nd-MythTV.html
 
Old 08-08-2008, 10:45 PM   #3
maestro52
Member
 
Registered: Aug 2003
Location: Texas
Distribution: Fedora 9
Posts: 177

Original Poster
Rep: Reputation: 30
Question Instructions are outdated and do not apply to FD9

I truly appreciate you referral {BBI}Nexus{BBI}, but the instructions do not apply to the FD 9 system. I did of course, adjust them accordingly as best I could, but I am not a programmer so I had to guess. Nevertheless, following this;
___________________________________________________________________________
Before you install the MythTV packages, we need to make sure the MySQL package we installed is up and running. Open up a Konsole and type the following:

CODE:
[root@localhost~]# service mysqld status
___________________________________________________________________________

I had to drop "service" and I still was presented with a large listing of commands that were stated as being necessary to use. Upon thorough reading I also remembered that my FD9 Service Management showed that MYSQL was up and running. However, I then read on and found this;

___________________________________________________________________________
When you installed mysql in the step above...it installed with no root password set. This is bad for security reasons...especially if you later plan on using the web plugin for MythTV where you can access program data from the web. To change this, do the following:

CODE:
[root@localhost~]# mysql -u root
___________________________________________________________________________

Disregarding the fact that MYSQL is already running on my computer, I thought about the "installed with no root password set" and tried to follow through with the instructions.

mysql -u root automatically presented an error stating "root" is not a user. I immediately assumed it meant I had to present ME (my root user name) and thus did so.

mysql accepted my root user name and thus moved on to the next step which was to give it a password. HOWEVER, no matter what I gave it, it would not accept it. I even tried to use my root password, but no way would it accept anything I gave it.
_________________________________________________________________________


Configuration

To setup mythtv's backend, we're going to run myth-setup (that's the command you can run from a konsole as well). This will 'setup' our configuration for when we fire up the mythbackend. However, we need to give the MySQL database structure so that the data can be stored inside of it. To do this, MythTV gives you a .sql file that can be used to form the database structure.

CODE:
[root@localhost~]# su

CODE:
[root@localhost~]# mysql --user=root --password=passwordSETearlier < /usr/share/doc/mythtv-0.20/database/mc.sql
This logs you into the mysql console. You'll then be able to:

CODE:
[root@localhost~]# mysql> SET PASSWORD FOR root@localhost=PASSWORD('password');
_________________________________________________________________________

First, using su after it was already in root mode makes no sense, but then where it tells me to enter "--user=root" I had to put my root user name in place of root. After that I got error after eroor after error due to "--password=passwordSETearlier", duhhh I should have realized I had to use the previously set password, BUT it had not been accepted to begin with so I was and am at a loss!

I then decided to look ahead to see if I could find a way to discover the problem. Since my MYTHTV set up always tells me there is NO BACKEND, I figured I would see what happens with the following.
_________________________________________________________________________

[root@localhost gary]# mythbackend --upnprebuild
2008-08-08 18:44:53.581 Using runtime prefix = /usr, libdir = /usr/lib
2008-08-08 18:44:53.597 Empty LocalHostName.
2008-08-08 18:44:53.597 Using localhost value of localhost.localdomain
2008-08-08 18:44:53.619 New DB connection, total: 1
2008-08-08 18:44:53.637 Unable to connect to database!
2008-08-08 18:44:53.637 Driver error was [1/2005]:
QMYSQL3: Unable to connect
Database error was:
Unknown MySQL server host 'cpe.tij.cablemas.com.mx' (1)
_________________________________________________________________________

Low and behold! "cpe.tij.cablemas.com.mx" is set as mysql server and that was set by me near the beginning of trying to set up my mythtv. It was a misunderstanding on my part and I had changed it in teh mythtv set up, but for whatever odd reason mysql will not let it be changed. At least I do not know how to change it. cablemas is my internet server not mysql server. mysql is on my computer with everything else including mythtv. So I have told mythtv set up to use localhost or 127.0.0.1 and it just will not accept it.


So what do I do now??

 
Old 08-09-2008, 02:24 PM   #4
{BBI}Nexus{BBI}
Senior Member
 
Registered: Jan 2005
Location: Nottingham, UK
Distribution: Mageia 5, Linux Lite
Posts: 4,312

Rep: Reputation: 210Reputation: 210Reputation: 210
Sorry I'm no MySQL expert. Perhaps this guide will help you to reset things: http://www.netadmintools.com/art90.html Read through it and make sure you understand what actions it is asking you to perform. Unless indicated otherwise this should all be done as root.
 
Old 08-12-2008, 01:32 AM   #5
fotoguy
Senior Member
 
Registered: Mar 2003
Location: Brisbane Queensland Australia
Distribution: Custom Debian Live ISO's
Posts: 1,285

Rep: Reputation: 61
Code:
"No UPnP backends found"
This means that the mythbackend server is not running and myththv cannot connect to it.

First have you installed the database for mythtv?, If you haven't then you need to first. The script is called mc.sql here is the script.

Just use the one that suits your network id, make sure mysql is running before adding the database


mc.sql

class C
Code:
CREATE DATABASE if not exists mythconverg;
GRANT ALL ON mythconverg.* TO mythtv@"192.168.0.%" IDENTIFIED BY "mythtv";
FLUSH PRIVILEGES;
GRANT CREATE TEMPORARY TABLES ON mythconverg.* TO mythtv@"192.168.0.%" IDENTIFIED BY "mythtv";
FLUSH PRIVILEGES;
ALTER DATABASE mythconverg DEFAULT CHARACTER SET latin1;
class B

Code:
CREATE DATABASE if not exists mythconverg;
GRANT ALL ON mythconverg.* TO mythtv@"172.16.%" IDENTIFIED BY "mythtv";
FLUSH PRIVILEGES;
GRANT CREATE TEMPORARY TABLES ON mythconverg.* TO mythtv@"172.16.%" IDENTIFIED BY "mythtv";
FLUSH PRIVILEGES;
ALTER DATABASE mythconverg DEFAULT CHARACTER SET latin1;
class A

Code:
CREATE DATABASE if not exists mythconverg;
GRANT ALL ON mythconverg.* TO mythtv@"10.%" IDENTIFIED BY "mythtv";
FLUSH PRIVILEGES;
GRANT CREATE TEMPORARY TABLES ON mythconverg.* TO mythtv@"10.%" IDENTIFIED BY "mythtv";
FLUSH PRIVILEGES;
ALTER DATABASE mythconverg DEFAULT CHARACTER SET latin1;
save this file as mc.sql, then install the database as root

Code:
su
mysql < mc.sql

Now run mythtv-setup to set up the mythbackend server, this must also be done by root, otherwise you wont have access rights to the /dev directory where your card will be listed

Code:
mythtv-setup
during the setup, change any ipaddress of 127.0.0.1 or localhost to the real ipaddress of the mythtv box e.g. 192.168.0.50
Once everything is setup you can exit mythtv-setup, and run the mythbackend daemon, again you must be root

Code:
mythbackend &
This command will throw mythbackend into a background process so you can then close the command line without killing the daemon.

Then start your mythfrontend as a normal user

Code:
mythfrontend
Hope this helps you out
 
Old 08-24-2008, 03:13 AM   #6
maestro52
Member
 
Registered: Aug 2003
Location: Texas
Distribution: Fedora 9
Posts: 177

Original Poster
Rep: Reputation: 30
Question fotoguy; I do not have mysql, I have mysqld with more confusion

As I said, I have mysqld. The MYSQLD server has always been activated and running in the service management of FC9. At the same time, I have MYTHBACKEND server running in there as well. The problem appears to be the fact that my computer is looking at the Internet Service I am using as being my MYTHTV BOX and it is not!

During the beginning of me trying to activate MYTHTV I did not know what I was doing and told the setup that the IP was where I was getting my Internet from. It did not work just like nothing else did, but no matter what I did it would continue to believe the MYTHTV box was at cablemas.mx(the Internet service I use). That is bogus!

I only have one computer, I am using it for everything including MYTHTV. I imagine I must tell something like class C, B, or A to use whatever MY COMPUTER'S IP is. As is, I only know my computer as being localhost. How do I find my own IP address and how do I make setup stop trying to use cablemas.mx?



Oh yes, I am also unsure about the following text.

ALTER DATABASE mythconverg DEFAULT CHARACTER SET latin1;

Why do I tell it to use "latin1"? I am from the USA. I live in Mexico, but do everything in English.

Last edited by maestro52; 08-24-2008 at 03:17 AM.
 
Old 08-24-2008, 03:48 AM   #7
{BBI}Nexus{BBI}
Senior Member
 
Registered: Jan 2005
Location: Nottingham, UK
Distribution: Mageia 5, Linux Lite
Posts: 4,312

Rep: Reputation: 210Reputation: 210Reputation: 210
In your home folder, go to view then select show hidden files look for a folder named .mythtv and rename it. Now re-run your mythfrontend setup. If all goes well you can delete the renamed .mythtv folder as a new one will have been created.
 
Old 08-25-2008, 06:00 AM   #8
fotoguy
Senior Member
 
Registered: Mar 2003
Location: Brisbane Queensland Australia
Distribution: Custom Debian Live ISO's
Posts: 1,285

Rep: Reputation: 61
Quote:
Originally Posted by maestro52 View Post
As I said, I have mysqld. The MYSQLD server has always been activated and running in the service management of FC9. At the same time, I have MYTHBACKEND server running in there as well. The problem appears to be the fact that my computer is looking at the Internet Service I am using as being my MYTHTV BOX and it is not!
Mysqld is the samething, they just use the d at the end to let you know that it is a daemon service

Quote:
During the beginning of me trying to activate MYTHTV I did not know what I was doing and told the setup that the IP was where I was getting my Internet from. It did not work just like nothing else did, but no matter what I did it would continue to believe the MYTHTV box was at cablemas.mx(the Internet service I use). That is bogus!
Not too sure why it would keep looking outside the network, if you have made a few changes and it still continues to point to your ISP, then it maybe the way your computer is connected to your ISP.

Some ISP's only allow one computer and the ipaddress, and the name of the computer will be issued by the ISP themselves. This may also depend on what sort of connection you have, Dial-up, Cable or ADSL.


Quote:
I only have one computer, I am using it for everything including MYTHTV. I imagine I must tell something like class C, B, or A to use whatever MY COMPUTER'S IP is. As is, I only know my computer as being localhost. How do I find my own IP address and how do I make setup stop trying to use cablemas.mx?
I don't use Fedora myself, so I couldn't say where it would be, but I would look for something related to networking. It should have something there to tell what the ipaddress is, most likely would have to be root to access the information

Quote:
Oh yes, I am also unsure about the following text.

ALTER DATABASE mythconverg DEFAULT CHARACTER SET latin1;

Why do I tell it to use "latin1"? I am from the USA. I live in Mexico, but do everything in English.
Don't worry about the latin1, it's not the latin language, so you can keep it as it is.
 
Old 08-27-2008, 04:12 PM   #9
maestro52
Member
 
Registered: Aug 2003
Location: Texas
Distribution: Fedora 9
Posts: 177

Original Poster
Rep: Reputation: 30
Question fotoguy??

I am still confused, but I have Cable Internet. They give me Internet, TV, and Telephone. Although I am not really on a network, since I only have one computer, my so called Network Configuration is as follows;

Hostname: localhost.localdomain
Primary DNS: 200.77.213.251
Secondary DNS: 200.77.213.250
DNS search path: cpe.tij.cablemas.com.mx

So, what do I do now? Is my computer being named as a part of cablemas, so to speak?
 
Old 08-27-2008, 04:35 PM   #10
{BBI}Nexus{BBI}
Senior Member
 
Registered: Jan 2005
Location: Nottingham, UK
Distribution: Mageia 5, Linux Lite
Posts: 4,312

Rep: Reputation: 210Reputation: 210Reputation: 210
In your home/<username>/.mythtv folder is a file named config.xml. Open it up with a text editor (kwrite or something similar) and you should see this:
Code:
<Configuration>
  <UPnP>
    <UDN>
      <MediaRenderer>62a8afbc-f945-47d6-8848-4c6b065b0301</MediaRenderer>
    </UDN>
    <MythFrontend>
      <DefaultBackend>
        <DBHostName>cpe.tij.cablemas.com.mx</DBHostName> <- If the name of your cable provider is here, change it to read 127.0.0.1
        <DBUserName>mythtv</DBUserName>
        <DBPassword>mythtv</DBPassword>
        <DBName>mythconverg</DBName>
        <DBPort>0</DBPort>
      </DefaultBackend>
    </MythFrontend>
  </UPnP>
</Configuration>
then save the file, or make the required change by running mythtv-setup again. Or post the contents of your config.xml file here to this thread.

Last edited by {BBI}Nexus{BBI}; 08-27-2008 at 04:38 PM. Reason: addition instructions added
 
Old 08-27-2008, 07:03 PM   #11
maestro52
Member
 
Registered: Aug 2003
Location: Texas
Distribution: Fedora 9
Posts: 177

Original Poster
Rep: Reputation: 30
Question .mythtv config.xml

<Configuration>
<UPnP>
<UDN>
<MediaRenderer>8606d060-17d1-4071-839d-2d83fd2f182b</MediaRenderer>
</UDN>
</UPnP>
</Configuration>

That is all I see. So I really have no idea what is wrong. As such, I am (pardon the old slang) going bonkers! I even bought a large roof antenna to eventually connect to my pcHDTV 5500 card, but I so far cannot even get mythtv up and running. Why does "mythbackend --upnprebuild" show me MySQL server host 'cpe.tij.cablemas.com.mx' with the config.xml showing nothing?

I must be doing something wrong.
 
Old 08-27-2008, 07:22 PM   #12
maestro52
Member
 
Registered: Aug 2003
Location: Texas
Distribution: Fedora 9
Posts: 177

Original Poster
Rep: Reputation: 30
Question OH yeah!

Now I have taken whatever I could find that was related to mythtv out of my computer because I assumed there was something wrong with it or the way I had it installed. Would that be why the .mythtv config.xml shows nothing? Of course, mythbackend and mysqld are still running (supposedly).

As is, now I am trying to decide whether to reinstall mythtv and try to set it up again or just rely on xine. Of course, while I realize hdxine will show me nothing until I connect the outside antenna and thus mythtv would also not show me anything until I do so, I was told mythtv was better than xine. It is just that I had problems with the darn mysql and I do not know how to prevent myself from repeating the problem.

Things would be fantastic if there was an instruction manual with specific step by step instructions. I follow instructions very well, but I know every computer is somewhat different than every other computer in some way or the other, so I am really becoming frustrated.

I truly appreciate everyone helping me. I just hope we all figure this out. Should I just say screw it and use xine anyway?
 
Old 08-27-2008, 07:46 PM   #13
{BBI}Nexus{BBI}
Senior Member
 
Registered: Jan 2005
Location: Nottingham, UK
Distribution: Mageia 5, Linux Lite
Posts: 4,312

Rep: Reputation: 210Reputation: 210Reputation: 210
I know nothing about using Xine in this way. The instructions I followed were from the MythTV site: http://www.mythtv.org/docs/mythtv-HOWTO-9.html#ss9.1 Personally when I try to do something and it doesn't work as expected, I remove/undo all that I have done so far and start again from scratch.
 
Old 10-15-2008, 05:03 AM   #14
fotoguy
Senior Member
 
Registered: Mar 2003
Location: Brisbane Queensland Australia
Distribution: Custom Debian Live ISO's
Posts: 1,285

Rep: Reputation: 61
Sorry for the late reply, I haven't received any notifications for this thread, and a new job just doesn't give you the time.

OK, when you start mythfrontend, by default will try to connect to a local mysql server, if one isn't found it will then try to find one on the network, if your modem is part of your isp's network, then that would explain why it is looking oustide your network. Mythtv gets in information about the mysql server from the mysql.txt found in the hidden .mythtv from your home directory. Here is my file you can use and modify to hopefully get mythtv to look at your machine for the mysql server.

~/.mythtv/mysql.txt


Code:
DBHostName=10.0.0.2

# By default, Myth tries to ping the DB host to see if it exists.
# If your DB host or network doesn't accept pings, set this to no:
#
DBHostPing=no

DBUserName=mythtv
DBPassword=mythtv
DBName=mythconverg
DBType=QMYSQL3

# Set the following if you want to use something other than this
# machine's real hostname for identifying settings in the database.
# This is useful if your hostname changes often, as otherwise you
# will need to reconfigure mythtv (or futz with the DB) every time.
# TWO HOSTS MUST NOT USE THE SAME VALUE
#
LocalHostName=mainMyth

# If you want your frontend to be able to wake your MySQL server
# using WakeOnLan, have a look at the following settings:
#
#
# The time the frontend waits (in seconds) between reconnect tries.
# This should be the rough time your MySQL server needs for startup
#
#WOLsqlReconnectWaitTime=0
#
#
# This is the number of retries to wake the MySQL server
# until the frontend gives up
#
#WOLsqlConnectRetry=5
#
#
# This is the command executed to wake your MySQL server.
#
#WOLsqlCommand=echo 'WOLsqlServerCommand not set'
Also mysql for security reasons only allows localhost or 127.0.0.1 to connect to it, if you set up the mythtv database to allow connections from the network, like the database script that i posted ealier, then you may not be able to connect. It may be better to install the default script and to only allosw the localhost to connect.

Code:
CREATE DATABASE if not exists mythconverg;
GRANT ALL ON mythconverg.* TO mythtv@localhost IDENTIFIED BY "mythtv";
FLUSH PRIVILEGES;
GRANT CREATE TEMPORARY TABLES ON mythconverg.* TO mythtv@localhost IDENTIFIED BY "mythtv";
FLUSH PRIVILEGES;
ALTER DATABASE mythconverg DEFAULT CHARACTER SET latin1;
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mythtv .20.2 channels not showing up??? cbradlea Linux - Software 2 10-04-2007 05:35 PM
Scanning ATSC channels in mythtv using ATI HDTV Wonder yuchai Linux - Software 0 09-18-2007 01:55 PM
MythTV - can't scan for channels cdhgee Linux - Software 3 03-12-2006 12:29 PM
Can't change channels in MythTV with Slackware 10.1 NetRAVEN5000 Linux - Software 2 06-15-2005 05:09 PM
New to MythTV howto configure channels sendas4 Linux - Software 0 11-16-2004 06:37 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora

All times are GMT -5. The time now is 10:01 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration