LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices


Reply
  Search this Thread
Old 04-10-2004, 09:36 PM   #1
chile712
Member
 
Registered: Feb 2004
Posts: 61

Rep: Reputation: 15
Question help w/ mp3player


im trying to figure out how to access my mp3 play on fedora
i look to see it fedora detects and it does. Hardware browser see it as a hard drive
it says:
Device start end MB type
/dev/sda
sda1 1 1011 215 fat16

i know there's a way to access it . Can someone help me out here and tell me how ?

i did a search and found this command:

mount -t vfat /dev/sda1 /mnt/movo

but it tells me:

/mnt/movo does nt exist

Last edited by chile712; 04-10-2004 at 09:59 PM.
 
Old 04-11-2004, 08:06 AM   #2
adz
Senior Member
 
Registered: Jun 2003
Location: Sydney
Distribution: Debian, FreeBSD
Posts: 1,713

Rep: Reputation: 53
Try an mkdir /mnt/movo and then retry the mount command.
 
Old 04-11-2004, 12:06 PM   #3
Boow
Member
 
Registered: Feb 2004
Distribution: Slackware 10.2
Posts: 669

Rep: Reputation: 32
you might need the ntfs driver read the trouble shooting thread at the top of the fedora forum.

Last edited by Boow; 04-11-2004 at 12:08 PM.
 
Old 04-11-2004, 02:56 PM   #4
wiraone
Member
 
Registered: Nov 2003
Location: Diawang-awangan
Distribution: Ubuntu Hoary!
Posts: 319

Rep: Reputation: 30
NTFS driver is needed if the drive is formatted using NTFS .. most if not all usb keys, MP3 players and PDAs are using FAT instead of NTFS.
 
Old 04-11-2004, 03:00 PM   #5
chile712
Member
 
Registered: Feb 2004
Posts: 61

Original Poster
Rep: Reputation: 15
i figure it out, but now it wont let me copy music to it any more. now it tells me it a read only. this what i did and it worked:
started terminal

cd /
cd mnt
mkdir movo
mount /dev/sda /mnt/movo

it started to work for a while. next i remove the music so i could copy other music and now it says "read only"

i've even login as root and it still tells me the same thing " ready only"
 
Old 04-11-2004, 05:48 PM   #6
adz
Senior Member
 
Registered: Jun 2003
Location: Sydney
Distribution: Debian, FreeBSD
Posts: 1,713

Rep: Reputation: 53
Add a "-o rw" to the command and see what happens.
 
Old 04-11-2004, 05:57 PM   #7
motub
Senior Member
 
Registered: Sep 2003
Location: The Netherlands
Distribution: Gentoo (main); SuSE 9.3 (fallback)
Posts: 1,607

Rep: Reputation: 46
It seems to me that the "rw" option won't so much help as the only users who are going to get rw for that folder are going to be root and the root group, as the default owners of a mount point in the /mnt folder mounted manually, unless otherwise specified. I suspect that it worked while you were still in the root terminal, and stopped once you became a regular user again.

You might try -o rw,users,uid=your_username for a temporary workaround, but in the end you'd do best to read man fstab and man mount to learn how to put a permanent line in /etc/fstab to automate this a bit.
 
Old 04-11-2004, 08:56 PM   #8
chile712
Member
 
Registered: Feb 2004
Posts: 61

Original Poster
Rep: Reputation: 15
so what your are saying is that, the process should look like this:

cd /
cd mnt
mkdir movo
mount /dev/sda /mnt/movo -o rw,users,uid=your_username


should i log in as " su " ?
 
Old 04-11-2004, 10:19 PM   #9
adz
Senior Member
 
Registered: Jun 2003
Location: Sydney
Distribution: Debian, FreeBSD
Posts: 1,713

Rep: Reputation: 53
No open up /etc/fstab and have a look. It's pretty self-explanatory. If you have any problems, do a man fstab and that will tell you what's what.
 
Old 04-12-2004, 04:13 PM   #10
chile712
Member
 
Registered: Feb 2004
Posts: 61

Original Poster
Rep: Reputation: 15
ok im more lost now. i look at the fstab and i took a look at the help file in the kicker and this is what i think i should put:

/dev/sda /mnt/movo vfat16,noauto,user,ro 0 0

if this is wrong please help me out and tell me what to type in.

Last edited by chile712; 04-12-2004 at 04:29 PM.
 
Old 04-12-2004, 06:15 PM   #11
adz
Senior Member
 
Registered: Jun 2003
Location: Sydney
Distribution: Debian, FreeBSD
Posts: 1,713

Rep: Reputation: 53
I'd change "vat16" to "vfat" and take away the comma after it. Then change the "ro" to an "rw". So in other words it would look soemthing like:
Code:
/dev/sda  /mnt/movo  vfat  noauto,user,rw  0  0
Then to mount it, you'd simply type mount /mnt/movo or mount /dev/sda.
 
Old 04-12-2004, 06:39 PM   #12
chile712
Member
 
Registered: Feb 2004
Posts: 61

Original Poster
Rep: Reputation: 15
Smile

i'll try it when i get home later. Thanx alot Adz, Motub and Boow. You guys know how to make a feel welcome here. And thanx for being patient w/ me.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
boot linux from mp3player possible? Itachi Linux - Newbie 3 09-10-2005 08:18 AM
df -h says that mp3player storage is used 78% samel_tvom Linux - Hardware 6 05-01-2005 06:21 PM
sweex 128mb, a mp3player punker Linux - Hardware 2 04-17-2005 10:10 AM
MP3player hari78 Linux - Software 2 12-12-2004 05:35 AM
Controlling /dev-device for USB-Mp3player (and other) Trygleren Linux - Hardware 2 08-30-2004 05:15 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora

All times are GMT -5. The time now is 06:24 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration