LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Fedora (https://www.linuxquestions.org/questions/fedora-35/)
-   -   help w/ mp3player (https://www.linuxquestions.org/questions/fedora-35/help-w-mp3player-168633/)

chile712 04-10-2004 09:36 PM

help w/ mp3player
 
im trying to figure out how to access my mp3 play on fedora
i look to see it fedora detects and it does. Hardware browser see it as a hard drive
it says:
Device start end MB type
/dev/sda
sda1 1 1011 215 fat16

i know there's a way to access it . Can someone help me out here and tell me how ?

i did a search and found this command:

mount -t vfat /dev/sda1 /mnt/movo

but it tells me:

/mnt/movo does nt exist

adz 04-11-2004 08:06 AM

Try an mkdir /mnt/movo and then retry the mount command.

Boow 04-11-2004 12:06 PM

you might need the ntfs driver read the trouble shooting thread at the top of the fedora forum.

wiraone 04-11-2004 02:56 PM

NTFS driver is needed if the drive is formatted using NTFS .. most if not all usb keys, MP3 players and PDAs are using FAT instead of NTFS.

chile712 04-11-2004 03:00 PM

i figure it out, but now it wont let me copy music to it any more. now it tells me it a read only. this what i did and it worked:
started terminal

cd /
cd mnt
mkdir movo
mount /dev/sda /mnt/movo

it started to work for a while. next i remove the music so i could copy other music and now it says "read only"

i've even login as root and it still tells me the same thing " ready only" :Pengy:

adz 04-11-2004 05:48 PM

Add a "-o rw" to the command and see what happens.

motub 04-11-2004 05:57 PM

It seems to me that the "rw" option won't so much help as the only users who are going to get rw for that folder are going to be root and the root group, as the default owners of a mount point in the /mnt folder mounted manually, unless otherwise specified. I suspect that it worked while you were still in the root terminal, and stopped once you became a regular user again.

You might try -o rw,users,uid=your_username for a temporary workaround, but in the end you'd do best to read man fstab and man mount to learn how to put a permanent line in /etc/fstab to automate this a bit.

chile712 04-11-2004 08:56 PM

so what your are saying is that, the process should look like this:

cd /
cd mnt
mkdir movo
mount /dev/sda /mnt/movo -o rw,users,uid=your_username


should i log in as " su " ?

adz 04-11-2004 10:19 PM

No open up /etc/fstab and have a look. It's pretty self-explanatory. If you have any problems, do a man fstab and that will tell you what's what.

chile712 04-12-2004 04:13 PM

ok im more lost now. i look at the fstab and i took a look at the help file in the kicker and this is what i think i should put:

/dev/sda /mnt/movo vfat16,noauto,user,ro 0 0

if this is wrong please help me out and tell me what to type in. :study:

adz 04-12-2004 06:15 PM

I'd change "vat16" to "vfat" and take away the comma after it. Then change the "ro" to an "rw". So in other words it would look soemthing like:
Code:

/dev/sda  /mnt/movo  vfat  noauto,user,rw  0  0
Then to mount it, you'd simply type mount /mnt/movo or mount /dev/sda.

chile712 04-12-2004 06:39 PM

i'll try it when i get home later. Thanx alot Adz, Motub and Boow. You guys know how to make a :newbie: feel welcome here. And thanx for being patient w/ me.


All times are GMT -5. The time now is 03:10 PM.