-   Fedora (
-   -   Gtk-WARNING **: cannot open display: (

lijomali 11-10-2005 04:48 PM

Gtk-WARNING **: cannot open display:
Does anybody know why I get this message after trying to open etherape in remote fedora core 3 machine.

The error message is:

(etherape:10950): Gtk-WARNING **: cannot open display:


acid_kewpie 11-10-2005 05:30 PM

probably cos you're trying to run it as root. you need to allow root to access your x server first. run "xhost +localhost" as your normal user.

lijomali 11-10-2005 05:56 PM

it shows the same error for both normal user and root


acid_kewpie 11-10-2005 06:06 PM

oh.. well let's start by defining "remote" then... what are ALL the machines involved in this running? how are they connected?

lijomali 11-10-2005 06:28 PM

There are 30 machines in this network and one NIS server is also running in the network, all machines are configured as NIS Client. I tried(from fedora core 3) to connect remote machine as both nis user and root, But the error was same. Another thing is that the connection was succesful when i tried it from RedHat 9. I used "ssh" to connect to remote machine.


spooon 11-10-2005 07:21 PM

Did you enable X forwarding? With something like "ssh -Y user@host" (-X for older versions).

lijomali 11-10-2005 07:43 PM

Now it works fine, thank you very much


All times are GMT -5. The time now is 03:52 PM.