LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Fedora (https://www.linuxquestions.org/questions/fedora-35/)
-   -   grub> promt on new Fedora Core 4 install (https://www.linuxquestions.org/questions/fedora-35/grub-promt-on-new-fedora-core-4-install-390372/)

towndrunk 12-07-2005 11:41 PM

grub> promt on new Fedora Core 4 install
 
I had a single boot installation of Redhat 9.0 and decided to convert to Fedora Core 4 as an upgrade. It has given me nothing but problems. If I do the upgrade from 9.0 it will not boot. So I did a new install with Fedore Core 4 and did an automatic partition, deleting all other partitions. When I do, the system boots to a grub> promt.

I'm a little new to Linux, but I don't understand why this would occur on a new installation. I've tried upgrading the grub boot with the old 9.0 disks, as well as changing the options with the new Fedora Core 4 disks. I have only this drive installed with this one distibution of Linux.

Any help would be greatly appreciate. Thanks.

shams 12-08-2005 06:30 AM

use the fedora firs cd as rescue and reinstall the grub ot the mbr read this link

towndrunk 12-08-2005 01:18 PM

I tried step six of your guide, "How to reinstall the grub to mbr or root partition?"

I followed the directions, and even did it over again with other options drive numbers, to make sure that I did it correct.

With the root (hd0,x) command I got:
x=1 Filesystem type unknown, partition type 0X83.
x=2 Filesystem type unknown, partition type 0X83.

With the setup (hd0,0) command I got:
as 0 Error 17: Could not mount selected partition.
as 1 Checking if "/boot/grub/stage1" exists. . . no
Checking if "/grub/stage1" exists. . . no
Error 15: file not found

I'm not proficient with Linux, but when I installed Fedora my partitions did look a little weird. There was some LVM Volume Groups listed first, and that is where the grub was pointing to o the install. I tried doing an upgrade to Fedora and changing the grub bootloader there, but it says something about not being able to find a Kernel or something.

Thanks for your help so far.

towndrunk 12-09-2005 02:49 AM

I've installed again with the same problem. Does anyone have any thought as to what I should try next. I've been working on this for the last week now, and I'm about ready to call it quits for a while and come back to it.

shams 12-09-2005 09:25 AM

try to boot from grub prompt read http://shamsweb.50webs.com/page3.html#grubp

Gethyn 12-12-2005 06:34 AM

Personally I'd try installing with manual partitioning, and avoid using LVM. It caused me problems on my last install too.


All times are GMT -5. The time now is 09:35 AM.