-   Fedora (
-   -   Grub does not boot after kernel upgrade (secure boot disabled) (

ggna 09-14-2013 08:27 AM

Grub does not boot after kernel upgrade (secure boot disabled)

after performing a kernel upgrade, grub2 does not boot into Fedora 19 any more.

I had installed FC19 with secure boot disabled.

When I try to enable secure boot again from the BIOS, I probably wasn't able to sign either grub2 or the (new) kernel properly.

If I try to start the newest kernel with secureboot disabled, I am prompted with the error message:

Secure boot not enabled
alloc magic is broken at ...

whereas if I enable secureboot, I am requested to "Select an X509 certificate to enroll".

I can in fact still boot Win8 (both with and without secure boot), and fortunately can still boot the kernel prior to the upgrade (without secure boot, of course). I immediately set installonly_limit=0 in /etc/yum.conf , in order to avoid future kernel upgrades to clean that working kernel!

Available documentation on secureboot/UEFI/shim is not so clear ...

Any help will be deeply appreciated!



ggna 09-16-2013 11:45 PM

It might be a bug, possibly not related to secure boot. See

All times are GMT -5. The time now is 06:55 AM.