LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Fedora (https://www.linuxquestions.org/questions/fedora-35/)
-   -   grub and lilo question (https://www.linuxquestions.org/questions/fedora-35/grub-and-lilo-question-139998/)

enchant 01-29-2004 10:56 AM

grub and lilo question
 
Hi,

I was using lilo as my boot loader for dual-boot between windows xp and FC1. Then I installed grub on the MBR of my machine ( /sbin/grub-install /dev/hda). It doesn't work. So I boot into FC1 use floppy and then I noticed lilo is actually on the partition where /root sits, in my case,/dev/hda2. How did this happen ?

But I boot into FC1 anyway. Since grub is not working, I reinstalled lilo, reboot, works. Later I correct some problem with grub.conf file, installed grub again ( fatal mistake ! it turns out ). Reboot, I did see graphical grub boot screen, but when i chose to boot FC1, I got a blank screen, nothing is happenging. I tried to reboot from floppy. same thing. :(

My guess is somehow lilo still sits on /dev/hda1 and it is corrupted. Can someone explain to me what had happened and what are my options are ? Would reinstall FC1 help ?

Thanks in advance,

Enchant

jailbait 01-29-2004 04:32 PM

"I noticed lilo is actually on the partition where /root sits, in my case,/dev/hda2. How did this happen ?"

the boot= parameter in /etc/lilo.conf tells lilo where to install the lilo bootloader. At some point you or the FC1 installer must have issued the lilo command with boot=/dev/hda2 instead of boot=/dev/hda. Make sure that /etc/lilo.conf has boot=/dev/hda

" Would reinstall FC1 help ?"

You don't need to be that drastic to solve this problem. Setting up either lilo or grub correctly can be done without a reinstall.

You are probably closer to having a working lilo than a working grub so I think you should work on getting lilo to work. Here is a lilo HOWTO:

http://tldp.org/HOWTO/LILO.html

___________________________________
Be prepared. Create a LifeBoat CD.
http://users.rcn.com/srstites/LifeBo...home.page.html

Steve Stites

enchant 01-29-2004 06:11 PM

I fixed the problem by editing /boot/grub/grub.conf on the grub prompt.


All times are GMT -5. The time now is 10:25 AM.