-   Fedora (
-   -   Got a problem upgrading to fedora 9 using preupgrade... (

The_Trooper 05-17-2008 05:13 PM

Got a problem upgrading to fedora 9 using preupgrade...
When preupgrade runs anaconda to upgrade my fedora 8 install and gives me the selection on which fedora 8 installation to upgrade and I choose one I will get an error message


Multiple devices on your system are labelled 448c9c30-4a09-40f6-8e01-d3c577cd250d.
Labels across devices must be unique for your system to function properly.

Please fix this problem and restart the installation process.

and when I look in /dev/disk/by-uuid I only find one link under that name. Could anyone please help me? Thanks.

The_Trooper 05-17-2008 06:31 PM

Hmm, I ran blkid in the terminal and found that indeed I do have 2 devices labeled 448c9c30-4a09-40f6-8e01-d3c577cd250d. Does anyone know how to change the labels?

Edit: I used tune2fs to fix this label issue. I simply ran


tune2fs /dev/sda3 -U random
Easy as pie. Thanks anyway, I hope this can help someone out.

billymayday 05-17-2008 06:34 PM

I'm sure there's a much simpler way, but I know that the Parted Magic live CD partitioning tool will let you do it.

Edit - I'm not sure is the name option for the parted command does what you need. See man parted

tibbitts 06-04-2008 07:39 PM

problem not solved for me
I upgraded F8 to F9 on my desktop (no LVM) without issue (well, not THIS issue...), but my (LVM) laptop has this problem. I found only (unused) raid devices with duplicate uuid labels, but I thought they were supposed to be duplicates.


All times are GMT -5. The time now is 12:15 PM.