-   Fedora (
-   -   Gnome Won't Start (X does) (

business_kid 11-08-2012 12:50 PM

Gnome Won't Start (X does)
I've forgotten a lot about Fedora. X starts, and I get the wallpaper. gnome fails. If I run startx as root (with X running) I get up a screen and a notice that says that gnome failed to start, but started in some fallback mode. It suggests graphics but it's doing fine with graphics.

There's network issues: lo fails to come up, wifi goes down in flames, but Networkmanager gets them up somehow - too well logged to read it. Xorg.0.log
throws an error on the modesetting module in X, and falls back to older methods

Every time I boot this (which isn't often) it updates itself, wrecks its
elf and won't reboot:=(

Things I have tried: making sense of the logs (a fair few errors along the way) and removing the pcie_aspm boot parameter, which didn't help.

EDIT: Alt_F2 works in X and I can start firefox with no menus at all. It seems there's a TrouSerS(:-o?) daemon in F-17 and it's not coming up. When I try, the config file is all commented out and when I finally trap an error from it, it "can't find a device to open" All the errors are going off to /dev/null, but I ran it as root. It has it's libs (ldd checks that out).

frankbell 11-08-2012 09:21 PM

Is there anything in /var/log/messages or /var/log/Xorg.0.log
that looks informative?

business_kid 11-09-2012 07:19 AM

There's a lot in the logs - some dweeb set the logging level to 'hysterical' where you don't want it, and to 'none' where you do.

/var/log/Xorg.0.log - tried to load module 'modesetting' but it dowsn't exist
Logs - tcsd won't start - 'can't find a device to open when I do it manually'. But that never stopped it booting before. The networking comes up jammy side down so 'lo' is coming up late which could cause messing. A lot of hysterical stuff which my jaundiced eye tends to ignore. If you want a log, it's no problem.
I'm running slackware on the same box and can set the log at zero and hang a complete boot up for you online. I do use AMD/ATI graphics, and they are long winded.

business_kid 11-10-2012 02:29 PM

Boot from /var/log/messages!208

That's the thing booting. Grep the log for tcsd, and the network is crazy.

Exact symptoms are: Boot to X, no menus, VTs, just wallpaper. No menus. Run Alt_F2 & start firefox. Menus appear; 'Activities' works; 'Windows' just shrinks the firefox window; Appliocations works - e v e n t u a l l y. "Idiot light" type icons also appear at top right (Display, Sound, bluetooth, wifi, battery & lusername). They work. No taskbar (Everything is default settings atm) Very awkward to work with this way.

business_kid 11-10-2012 03:18 PM

Marking this solved. It's not solved, but it no longer matters.

'Yum update' Threatened a 538MB download, and I felt "You can't be serious!" It wasn't - 211MB
350 installs, 329 cleanups from 142 downloads. I'm no longer running the same system. When It barfs again, I'll post a fresh thread.

I wanted a reason to bother compiling stuff I need in Slackware. I think I#ve just got it.

EDIT: It's _ACTUALLY_ solved. Thanks to all who contributed. They updated the bugs with fresh ones :-P. Now 2 services won't start, but they don't matter because gnome functions better. There's about 100 daemons more than I need running anyhow. But it's great to see the software I need sitting up with icons ready to roll.

/Note to self: Set this up a bit better before bellyaching.

All times are GMT -5. The time now is 05:18 AM.