-   Fedora (
-   -   Gnome Dictionary 2.8.0 toolbar applet: can't find host (

Kropotkin 03-25-2005 11:50 AM

Gnome Dictionary 2.8.0 toolbar applet: can't find host
Hi all,

I've grown quite fond of the gnome dictionary applet on the toolbar, but since a week or so ago, it can't connect with the server. I am using the default settings, is pingable, so it must be my system, but what? The Weather Report stopped working as well. :(

I am running Core 3.

awdac 03-25-2005 03:37 PM

I'm not familiar with those services themselves, but perhaps it's your firewall if they use ports other than 80. Try taking down the firewall right quick to see if it enables them: 'service iptables stop'

If that helps, put the firewall back up, figure out which ports they're using and make the adjustments. Are you sure the remote hosts are still providing the services you are looking for?

pjbgravely 04-04-2005 09:49 PM

The samething happened to me on Gnome 2.8 in Ubuntu Warty, but I did find that dropping the firewall let it work again. I am using firestarter, but updating it didn't help. I opened the port 2628 which it uses with no effect. This used to work with no open ports and now it won't.


Kropotkin 04-05-2005 03:23 AM

Well, I found that when I closed down Firestarter, Dictionary worked again -- and when I restarted Firestarter, it continued to work. Very weird. I don't know what to say...

Alas, the WeatherReport applet still doesn't work on my Core 3 desktop box, although it does on my laptop running Fedora Core 2 using the same ASDL connection


pjbgravely 04-05-2005 06:01 AM

I tried to find what port it was using besides 2628, but I could see nothing in the packet scans. I tried to change the port to 80, opened up a large band of ports, let in all traffic from the source, all with not success. Since nothing is hitting the firewall I am assuming that the packets are never making it out. That is strange because all ports are opened for outgoing.

I do have a treatment for the weather applet. If it will not update I switch it to another location , let it go there and then switch it back. Otherwise only a Gnome reboot will help. This is a pain but is still better than using weather bug:)


ming0 04-11-2005 02:16 PM

I have the exact same problem w/ the dictionary applet (I use firestarter and Ubuntu Hoary). Same exact symptoms as you, and still haven't found a cure :(

Please post here if you figure something out!

pjbgravely 04-15-2005 11:56 PM

The problem is with firestarter, for some reason it is blocking all incoming packets related to outgoing ones and not allowing related connections in. I checked the configuration in IP tables and it all looks good. If another update doesn't come through that fixes it soon, I am going to uninstall it and write my own firewall using webmin. I got firestarter just so it would be faster to open ports, but since it won't work right I will have to just write the rules myself. Using webmin, once you have the basics done, opening ports for web use is actually easy. I restrict all other services to my internal network so that is the only reason I have the firewall anyway. I leave it on, but I have to drop it to use the dictionary, or NFS or even Samba viewer.

All times are GMT -5. The time now is 03:24 PM.