-   Fedora (
-   -   Gnome = no sound, but aplay/firefox/vlc work w/ alsa (

nicky7 07-23-2009 02:54 PM

Gnome = no sound, but aplay/firefox/vlc work w/ alsa
History: (tldr below)

Started with fresh install of F11. Audio initially worked, however I couldn't do multiple streams. Also the 1/8" audio jacks weren't working. Hoping that pulseaudio had improved since F10, I installed a bunch of pulseaudio packages which killed my sound output. Pulse audio meter was showing sound for gnome events, but without actual output. Attempting to use pulseaudio mixer would crash pulse server within a few seconds. Interestingly, firefox was still using alsa and I could hear audio from it (still no multiple streams), but was NOT showing in the pulseaudio meter. I could set vlc to pulseaudio and it'd show up on the meter, but no sound. Setting vlc output to ALSA produced sound (provided it was the only stream) but would not show up on pulseaudio meter. The gnome-volume-control-applet was set to control pulseaudio so wouldn't actually adjust the sound I was hearing. I then ran 'yum remove pulseaudio' to revert back to alsa only and lost gnome-volume-control with the error "Waiting for sound system to respond.", so no volume control in gnome's notification area. Suddenly I found multiple streams were working under alsa, but gnome seems to still be stuck on pulseaudio. I've spent several hours trying to search and rescue my audio to no avail. This is the first time I'm asking a community for help. How do I get gnome to use alsa instead of pulse (I'm assuming this will also bring back my volume control)?

Gnome using broken/uninstalled pulseaudio instead of the working ALSA. How do I configure gnome to use ALSA.

aplay and speaker-test both produce sound.


$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: SB [HDA ATI SB], device 0: STAC92xx Analog [STAC92xx Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 0: SB [HDA ATI SB], device 1: STAC92xx Digital [STAC92xx Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 3: ATI HDMI [ATI HDMI]
  Subdevices: 1/1
  Subdevice #0: subdevice #0


$ cat /etc/asound.conf
@hooks [
    func load
    files [
    errors false

/etc/alsa/pulse-default.conf doesn't exist (but old f10 has same setup here and was working fine)


$ lspci | grep -i audio
00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA)
01:05.1 Audio device: ATI Technologies Inc RS780 Azalia controller

Opening 'System > Preferences > Sound' produces "Waiting for sound system to respond."

John VV 07-24-2009 11:18 AM

there is a bug in fedora 11 and pulse audio .
the current updates " should " have fixed that .

well seeing as fedora IS a testing distro ... things will break.

just remove pulseaudio and use alsa.

nicky7 07-24-2009 11:46 AM


just remove pulseaudio and use alsa.
That's exactly what I did.


I then ran 'yum remove pulseaudio'...
The problem is that gnome is still trying to use pulseaudio, and I can't find where I can change this setting. Everything else works. I think I can do this with /etc/asound.conf or ~/.asoundrc, but I haven't been able to determine what should go in there.

zoltrix 07-29-2009 01:58 PM

I have exactly the same issue . I have removed Pulseaudio as it doesnt behave well with skype. But now, gnome cant output any sound. KDE is fine. I am not getting any sound for notifications from Empathy messenger. Any way we can make Gnome talk to ALSA in fedora 11??

nicky7 08-21-2009 08:03 AM

There's a python script on fedoraforum that added an alsa capable volume control in the systray, but I'm still having no luck getting gnome to use alsa.

All times are GMT -5. The time now is 04:56 AM.