-   Fedora (
-   -   Getting "Untrusted Connection" in Firefox 22 on Fedora 19 (

hscast 08-08-2013 01:09 PM

Getting "Untrusted Connection" in Firefox 22 on Fedora 19
I have 2 systems that I installed Fedora 19 on. My test system has a 256GB SSD unencrypted. My main system has multiple HDDs that are all encrypted (LUKS on LVM2 setup). The main system (which did not have this problem while running Fedora 18 with Firefox 21), when I try to access my State Farm account to print my bill, I'll get the above mentioned warning. Clicking on "View Details" shows the following: uses an invalid security certificate.

The certificate is not trusted because the issuer certificate is not trusted.

(Error code: sec_error_untrusted_issuer).

I have tried firefox -profile to create an alternate profile and got the same results. I even renamed my .mozilla sub-dir so running Firefox would cause the creation of anew .mozilla sub-dir and contents. I have another user on the system, using that account will also give me the same results.

Reinstalling Ca-certificates package did not change anything neither did reinstalling Firefox. I have also tried installing Epiphany and Chrome. Chrome gave me the same results while Epiphany allowed me to login and access the desired document, though when I went to print it (tried both print to PDF & print to printer)Epiphany crashes.

So far it only seems to be "" that this happens. If I do click on the option ("I Understand The Risks") that allows me to add the certificate and it will allow me to login to my account, however it will present me with the warning again. When I add that certificate I lose all of the graphics and all text/field get vertically lined up against the left margin.

I'm thinking of just blowing off this install and start over again from scratch. But before I do that I'm willing to try any other suggestions, if anyone has any ideas what else it may be that is causing this. Also the site is fine when I access it from my test system, my wife's work laptop (WindersXP), her Nook and both our Android phones.

Scott C.

unSpawn 08-10-2013 05:53 AM

Both and show the certificate as valid. What does this return?

openssl s_client -connect -showcerts

hscast 08-10-2013 12:15 PM

I did finally resolve it real early this morning about 01:00 EDT

I had made several attempts to reinstall both Firefox & ca-certificates. Finally after running clean all in yum I made another attempt at removing Firefox and then I manually deleted firefox sub-dir in /usr/lib64 then reinstalled Firefox. I still had to manually add that certificate(s), and noticed that the option to make permanent was not grayed out. I was then able to login and access my account and documents that I needed. I'm still not 100% sure what caused it to do this, other than when the system had done the massive updates after initial install some downloaded yum files had somehow got mangled causing yum not to completely clean house after the attempts to reinstall these packages. Due to the graying out of that one field and its behaviour changed after all this, I suspect that it was a permission problem somewhere.

unSpawn 08-10-2013 08:03 PM

I doubt it was a permission problem (rather something with personal profiles) and that reinstalling software is the right way to diagnose problems. In the end you fixed it so good for you.

All times are GMT -5. The time now is 02:14 PM.