Download your favorite Linux distribution at LQ ISO.
Go Back > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Fedora This forum is for the discussion of the Fedora Project.


  Search this Thread
Old 03-11-2004, 04:18 PM   #1
Registered: Feb 2004
Location: Oklahoma, USA
Distribution: Ubuntu | Mac OS X 10.3
Posts: 143

Rep: Reputation: 15
Question Getting ALSA to work with 2.6.x

Has anyone had any luck getting ALSA to work with 2.6.x on Fedora FC1?

I've been pulling my hair out on this one for more than few days. I've search posts on this site and others, but just can't figure it out.

I have a Creative Labs Audigy card and have tried to follow the directions from ALSA

I've added their code (see below) into my /etc/modules.conf but my sound card doesn't get recognized at startup. I get an error about /dev/dsp. I can also go to KDE's Info Center and my sound card isn't recognized.

# ALSA portion
alias char-major-116 snd
alias snd-card-0 snd-emu10k1
# module options should go here

# OSS/Free portion
alias char-major-14 soundcore
alias sound-slot-0 snd-card-0

# card #1
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss

They talk about inserting the following modules into the kernel. I don't know what this means. "modprobe snd-emu10k1;modprobe snd-pcm-oss;modprobe snd-mixer-oss;modprobe snd-seq-oss"

I can run the modprobe statements above in the terminal and my sound card will show up in KDE's Info Center, but I don't know how to get them to load during start up.


Old 03-11-2004, 11:47 PM   #2
Registered: Feb 2004
Location: Oklahoma, USA
Distribution: Ubuntu | Mac OS X 10.3
Posts: 143

Original Poster
Rep: Reputation: 15
I was finally able to get ALSA to work under 2.6.4 with my Creative Labs Audigy sound card. Here's what I did.

1. Downloaded, compiled and installed ALSA driver v. 1.0.2c and version 1.0.2 lib and utils. I used ALSA's as a guide to compiling as I'm pretty new to Linux. I used driver 1.0.2c since this is the version of the module that came with kernel 2.6.4 (I found this in Info Center -> Sound). The latest version of the driver might work, I just didn't want to fool with it now
2. I added the code that ALSA's documentation told me to put into my /etc/modules.conf.
3. Executed the ./snndevices shell script that came with the driver's installation folder. Seemed to fix some stuff as I couldn't get alsamixer to work before I ran it.
4. Ran "alsaconf" which added some stuff to my /etc/modprobe.conf. From everthing that I've read, I shouldn't need anything in this file. At least in my installation, it was important to have the lines added to my modprobe.conf. For the longest time, I was stuck on step 2 and couldn't figure out why my sound card wasn't being recognized at startup. By adding the lines to /etc/modprobe.conf, the modules for my soundcard are loaded at startup, at least from what I can figure.
5. Ran "alsamixer" to un-mute my volume. It resets to mute everytime I reboot, but I'm working on the problem.

I'm just glad that it works now. The Sound Detection program throws out some error when I run it, but I can hear the test music playing.

Hope this helps some of you out there pulling their hair out with getting sound to work in kernel 2.6.x

- THX75

Of course, I found all of the info I needed on one webpage, after struggling for hours on my own

Here's a guy who did a kernel upgrade to 2.6 and he talks about his ALSA drivers.

I haven't been able to get my volume to automatically unmute at startup through my /etc/modprobe.conf, even after following the WIKI at

I found a workaround in a post on this website which basically uses Kmix to fix the problem.
Works for me so far. I did have to turn off aRS as I was getting a sound system CPU overload error at startup.

Last edited by THX75; 03-12-2004 at 02:03 AM.
Old 03-23-2004, 03:12 AM   #3
LQ Newbie
Registered: Mar 2004
Distribution: SuSE 9, Mandrake 10
Posts: 19

Rep: Reputation: 0
I'm also having a hard time getting my sound in Mdk 10 using 2 soundcards (M Audio, Audigy).

Have you tried alsactl for saving the card level settings?

Seems to have worked for me...

Dizzy V.
Old 03-23-2004, 10:04 AM   #4
Registered: Feb 2004
Location: Oklahoma, USA
Distribution: Ubuntu | Mac OS X 10.3
Posts: 143

Original Poster
Rep: Reputation: 15
Altctl store and restore worked when I typed it into the terminal, but when I used the recommended code from ALSA in my modeprobe, I couldn't get it to work when I restarted.

I'm now using 2.4.x and OSS and I'm going to wait until FC2 become final... or try Slackware.
Old 04-23-2004, 04:29 AM   #5
LQ Newbie
Registered: Apr 2004
Posts: 8

Rep: Reputation: 0
I'm still working on getting it working myself, but I can answer the question about modprobe. The 2.6 version kernels use modprobe.conf rather than modules.conf. No one ever seems to mention this however.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Getting ALSA to work a monkey Fedora 2 02-27-2005 01:22 AM
ALSA did't work ahmed1915 Linux - Newbie 4 01-03-2004 02:34 AM
got ALSA to work in root, need help getting it to work in my user profile ic3 Slackware 2 11-28-2003 11:32 PM
How does ALSA work? raypen Linux - Software 10 05-13-2003 05:39 PM
getting alsa driver to work kudos Slackware 4 04-19-2003 12:34 PM > Forums > Linux Forums > Linux - Distributions > Fedora

All times are GMT -5. The time now is 02:37 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration