-   Fedora (
-   -   fstab with upgrade to fedora 5 (

rik_cross 07-23-2006 06:32 PM

fstab with upgrade to fedora 5

just upgraded from fc4 to fc5. my fstab file hasn't changed, bit for some reason it's not mounting my /dev/hdb1 on startup. it does it only when i use 'mount' manually.

here's my fstab

[rik@pc1 ~]$ cat /etc/fstab
/dev/VolGroup00/LogVol00 / ext3 defaults 1 1
LABEL=/boot /boot ext3 defaults 1 2
/dev/devpts /dev/pts devpts gid=5,mode=620 0 0
/dev/shm /dev/shm tmpfs defaults 0 0
/dev/proc /proc proc defaults 0 0
/dev/sys /sys sysfs defaults 0 0
/dev/VolGroup00/LogVol01 swap swap defaults 0 0
/dev/hdb1 /mediadisc vfat user,noauto,noexec,umask=000 0 0

as i said, it hasn't changed since before fc5 upgrade.

when i do mount it manually, it mounts as read-only. how do i prevent this.

thanks for the help, i'm a relatively new linux user.


weibullguy 07-23-2006 09:44 PM


/dev/hdb1 /mediadisc vfat user,noauto,noexec,umask=000 0 0
Change the noauto to auto and it will mount at boot time. Add the rw option and you will be able to read/write. Here is a pretty good, to the point tutorial for the fstab file.

rik_cross 07-24-2006 04:35 AM

thank you, i'll try that. is there a reason why hdb1 still mounted on boot-up even with 'noauto' in fc4? like i said it worked before in fc4 when it was 'noauto'.


rik_cross 07-24-2006 11:45 AM

no luck
hi, i tried the above but still nothing. actually the drive now mounts, but is being reported as 0 files but only 30 gig of a 180 gig disk left. when i mount manually it then shows all files!

any ideas???



weibullguy 07-24-2006 11:48 PM

Regarding your first question, are you sure it was 'noauto' and the FC5 install didn't change it? Otherwise I don't know why except some deeper change the FC team made.

Regarding your second question, try deleting the ',umask=000'. Keep the last two 0's, you need those.

reddazz 07-25-2006 05:11 AM

Since this is not really a software question, I have moved this thread to the Fedora Forum to give it more exposure.

All times are GMT -5. The time now is 11:47 AM.