-   Fedora (
-   -   fstab and fedora 17 (

rmknox 01-31-2013 11:09 PM

fstab and fedora 17
If I put an entry in fstab should fedora 17 mount a partition for me at boot time?

I see a number of traditional things have changed in recent fedora's.

I put this line in fstab and it is not mounting my partition

/dev/sda3 /media vfat defaults 1 2

do I have an error?

kedarp 02-01-2013 12:27 AM

First of all create a folder in /media like 'new' and use it /media/new.

Run the command -

# mount -a

and see if it gives any errors.

John VV 02-01-2013 03:48 AM

you can not mount a partition directly to " / "
SELinux will stop it

that is a fat ? what ? fat32 partition ?

add a folder to /mnt ( mnt IS the preferred place in fedora )
the /media folder is used for AUTO mounting of dvd's , cd's usb-drives,...


su -
mkdir /mnt/
cd /mnt
chown ????:users

------ note replace ???? with YOUR user name !!! ------

then add to fstab
/dev/sda3 /mnt/ vfat defaults 1 2

that partition should auto mount and be in the left window on Nautilus
listed a a partition by it's size

rmknox 02-01-2013 10:34 AM

Thanks for the ideas

My question was motivated by the following

I note that Fedora no longer uses /media instead it uses /run/media

when I manually mount /dev/sda3 /media it works just fine

if i then type mount it re[plies

---snip ---
/dev/sda3 on /media type vfat (rw,relatime,fmask=0022,dmask=0022,codepage=cp437,iocharset=ascii,shortname=mixed,errors=remount-ro)

I previously had that command (mount /dev/sda3 /media) in a file named located in /etc/profile.d and it mounted at boot & login time
but it also tried to mount whenever i used terminal

thus i'm not so concerned with the directory where i do it even though the directory i selected is somewhat unconventional

my question is more like "does f17 still use /etc/fstab and do i have the correct syntax"

rmknox 02-01-2013 11:59 PM

Took your advice - added TwentyGig under media - changed fstab to mount there and it does.
Problem solved



All times are GMT -5. The time now is 08:38 AM.