-   Fedora (
-   -   Fresh copy of Fedora Core 4, Now time for Fonts! (

markb658 08-19-2005 05:31 AM

Fresh copy of Fedora Core 4, Now time for Fonts!
Ok, I have tried everything possible with my install of FC4 to get True type fonts looking good, So atm i am installing a completely new fresh copy on my linux box, so could someone pleas tell me how to get True Type fonts working with a new install of FC4, everything i need to donwload and that, becuase what im after is to use Tahoma as my main GUI font in KDE, and for it to look like it does in windows, because it kept looking all sharp and squashed.
So the install is nearly complete now, and any help will be aprecciated!

Thanks in advance.

reddazz 08-19-2005 06:09 AM

Download the fonts or get them from MS windows. Make a directory in /usr/share/fonts called msttf. Copy the truetype fonts there and do "mkfontdir" and "mkfontscale" in that directory (/usr/share/fonts/msttf). Log out and in again and your fonts will be ready for use. If you use GNOME, you may need to copy the fonts to ~/.fonts as well.

PeterRJG 08-19-2005 09:47 AM

Download the font, open up Nautilus, do fonts: in the location bar and drag and drop fonts into there. Can't remember if you need to restart X to see them, I don't think so.

Open up Control Centre (kcontrol) - go tho the Fonts section under Appearance and Themes - check the anti-alias box. Click on Configure and check Use Sub-Pixel Hinting and use Greyscale with a medium rating.

Smoothest fonts you've ever seen.
Compare the difference. The smudging of the links is due to jpg artifacting.

WhatsHisName 08-19-2005 11:21 AM

reddazz: Cool! You learn something new every day.

reddazz 08-19-2005 01:15 PM


Originally posted by WhatsHisName
reddazz: Cool! You learn something new every day.
I guess from your reaction, the method above worked for you. :)

WhatsHisName 08-19-2005 01:27 PM

Yes, it did. Itís nice to have Arial again.

All I did extra was to chown and chgrp to root and chmod to 755, just to be consistent with the other font folders. GNOME worked fine without any extra mods after logging out/in once.

sohmc 09-26-2005 08:08 PM

Fedora Core changed their font system
I had trouble with this initially. Fedora Core 4 is moving to a new font system called fontconfig. The details are available in their release notes. Here is the URL:

FC4 still has the old Xfont server so I want to keep both updated. Here's the script I wrote:


echo Rebuilding core X Font Server on /usr/share/fonts/local . . .
ttmkfdir -d /usr/share/fonts/local/ -o /usr/share/fonts/local/fonts.scale
mkfontdir /usr/share/fonts/local
echo done.

echo Rebuilding for fontconfig . . .
fc-cache /usr/share/fonts/local
echo done.

this assumes that tmkfdir, etc are in your path. Run as root.

Hope this helps someone!

All times are GMT -5. The time now is 01:20 AM.