-   Fedora (
-   -   Formating a USB Drive (

lmcilwain 09-28-2007 03:06 PM

Formating a USB Drive
Hello all,

I have 2 250GB hard drives that are formatted in the HFS+ format and I am trying to get them to be ext2/ext3 format but I am having issues using qtparted or gparted.

Can anyone give me a reliable way to format these drives? If through the command line, I will need step by step instructions since the last time that I tried that, I ended up formatting my system compeltely.

If gparted/qtparted actually work, can anyone provide a place where I can view documentation on how to use them properly?

My current system that is running FC7 is a Dell C800 that has x11 issues when trying to boot into the live cd so I don't have a way to make it so that the hard drive is not in use (if that is part of the problem)

PTrenholme 09-28-2007 05:07 PM

Your title suggests that these two drives are USB drives, but your question suggests that they (or, at least, one of them) may be your boot drive. Could you explain in more detail what you meant by USB?

If these are not your boot drive(s) and you're running as SU, just umount the partition(s) before using the partition editor.

It they are your boot drives, try starting the partition editor and then (e.g, by pressing Ctrl-Alt-F1) start another terminal session where you can umount the partition(s). If the partition editor has been loaded into memory (and/or swap), you should be able to finish the formatting. Of course, formatting your boot drive(s) will erase you system, so I wouldn't recommend it.

Also, if you are happy with the partitioning, use the mkfs command to do the formatting.

lmcilwain 09-28-2007 05:23 PM

Sorry for the confusion, I was stating that the last time I tried doing anything with formatting a hard drive, it was an external hard drive at the time but I did something with my boot drive and I ended up having to re-install.

At this time, this issue is with 2 external USB drives and I want to be able to change the file systems on them.

I thought that if I unmounted the drives, the partition editors wouldn't be able to find those drives to be able to edit them.

Once I unmount them how do I mount them again? Seeing as I didn't do the mount points when I initially plugged them in. They were just mounted to /media/drive

lmcilwain 09-29-2007 12:19 AM

So it looks like I might have been making a mountain out of a mole hill...

To format the USB drive it was as simple as

1. Right clicking on the desktop icon of the USB drive and selecting unmount
2. Opening Gparted and selecting that drive
3. Delete the current settings of that drive
4. Format the drive with ext2/ext3 file format
5. Unplug the USB Drive from the system and then Plug it back in, the OS will re detect it.

All times are GMT -5. The time now is 06:25 AM.