LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices


Reply
  Search this Thread
Old 01-24-2004, 03:01 AM   #1
wampfler
Member
 
Registered: Nov 2003
Location: switzerland
Distribution: Fedora Core 1.0/Gentoo
Posts: 35

Rep: Reputation: 15
Unhappy Fluxbox vs GDM/xfs


I hope there are a lot of fedora-fluxbox-users out there...(it's the wm of the year...)
when i start fluxbox from a failsafe_terminal, it takes 1 sec to start.
when i start fluxbox from gdm, it takes more than 2 minutes to start, because xfs (font server) is grabbing all the processor time...
is there a possibility to have a fast starting fluxbox?
thanks in advance
 
Old 01-24-2004, 04:43 AM   #2
kasperhans
Member
 
Registered: Oct 2003
Location: right behind the moon
Distribution: gentoo
Posts: 466

Rep: Reputation: 30
remove gdm from your /etc/X11/xinit/xinitrc and add fluxbox as program to start now reboot if it works great if not you have also to change the runlevel your system boots into to terminal mode and then manualy login and type startx
 
Old 01-24-2004, 05:26 AM   #3
wampfler
Member
 
Registered: Nov 2003
Location: switzerland
Distribution: Fedora Core 1.0/Gentoo
Posts: 35

Original Poster
Rep: Reputation: 15
but i want to use gdm
 
Old 08-19-2004, 11:59 PM   #4
koheleth
LQ Newbie
 
Registered: Aug 2004
Distribution: Gentoo, Debian Sarge
Posts: 10

Rep: Reputation: 0
Set LC_ALL=C in your environment

As far as I can tell, the issue is related to a difference between the way that FC2 handles locales and the way Fluxbox handles locales.

So, the short answer to your problem is that you need to set the environment variable LC_ALL=C in the appropriate .Xclients file (usually ~/.Xclients-localhost.localdomain:0). However, every time you run switchdesk, you will have to re-edit that.

I came up with an all-around better solution (one that makes Fluxbox as usable on FC2 as it is on Gentoo). I documented the process here: http://aleph-null.tv/go.php/20040819-1137-374.xml

My PIII 700 Toshiba Tecra 8100 used to take over 2 minutes to load Fluxbox. Now it takes exactly six seconds (which includes the time starting xscreensaver and setting the background). That's the Fluxbox we know and love.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Fluxbox & GDM R¬dical_úD SUSE / openSUSE 1 06-23-2005 01:43 AM
Fluxbox from gdm bratch Linux - Software 2 04-07-2005 08:24 AM
gdm no option for fluxbox b0rcked Debian 14 05-02-2004 02:02 PM
gdm overwrites /etc/gdm/Session/fluxbox _flaab_ Mandriva 0 12-21-2003 10:58 AM
fluxbox / gdm ilhbutshm Linux - Newbie 1 11-27-2003 08:52 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora

All times are GMT -5. The time now is 07:35 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration