-   Fedora (
-   -   floppy handling fedora 10 (

Lena-Marie 04-22-2009 05:29 PM

floppy handling fedora 10
At first i like to say hallo to everybody and please to excuse my very bad English, but i hope you'll understand what i mean.

My problem is, how to handle the floppy drive in Fedora 10.
When i open "Computer" at my desktop. i see icons for my cd/dvd my disks and so on and all works as expected, but when i insert a floppy in the drive at first nothing happens (not like inserting a flash stick or a cd/dvd, which are mounted automatically) and when i try to open by double click, he tells me not to be able to mount the drive.
If i try to mount by "mount -t auto /dev/media/floppy" the drive mounts as expected.
After that, i have inserted the following to the fstab:

/dev/fd0 /media/floppy auto rw,user,noauto 0 0
From now on i have two icons in my panel when i mount a floppy, one called "Diskettenlaufwerk", witch won't work and one called floppy, witch works.
But auto-mounting when i insert a floppy into the drive still doesn't work and only root can write to it also when mounted by a normal user.

My question now is, is there a way to handle a floppy like all other removable storage device? Mounting when inserted / connected and unmouted by the eject arrow.

Will be nice if someone has any idea how to do that.

Greetings from Hamburg/Germany,


P.S.: Since i have formatted and mounted the floppy with the "User mounting tool" i can write to it as normal user.
So there are only two things to fix: auto-mounting and only one working icon instead of two

P.P.S.: Ok, so far i have fixed it by adding the following to fstab:

/dev/fd0 /media/floppy auto rw,users 0 0

chmod 777 /dev/fd0
to rc.local

From now on i can mount, read, write and unmount the floppy.
Only thing left is an error dialog, telling something like

Unable to mount location
Internal error: No mount object for mounted volume

but this is a known bug ( see bugzilla )
Auto-mounting like usb-drives is impossible, because hal is unable to poll floppy-drives, but that doesn't matter.

unSpawn 05-03-2009 06:05 AM

Thanks for posting back the bug and fix!

All times are GMT -5. The time now is 02:34 PM.