-   Fedora (
-   -   Flash and Pulseaudio push cpu to 100% (

Neruocomp 08-05-2009 12:53 PM

Flash and Pulseaudio push cpu to 100%
I'm using 64bit Fedora 11 and have been having problems lately with flash. I was originally using the 32bit flash with nswrapper but when I started having problems I switched over to using the 64bit flash but still get the same behaviour.

I'll watch a flash video only to have playback freeze up for a few moments. It continues at some point but very choppy and no sound. I close out firefox and try again and things work for a while then it happens again. So this is what I think is happening.

Open firefox(and top in terminal)
Watch a flash video(anywhere, doesnt matter)
After a little while, maybe a few minutes playback freezes up and sound cuts out. In top I can see that pulseaudio starts using alot of cpu. Flash playback returns but is very choppy and still no sound and now firefox(or nsplugin when using nswrapper for 32bit flash) is using alot of cpu.

Any ideas?

paulsm4 08-07-2009 12:07 AM

Hi -

I presume you're running the latest/greatest version of Flash 10:

And the latest version of Firefox 3.x:

Many people who've reported problems in earlier releases have been quite pleased after upgrading.


If you know you've got the current version, and you're still having problems, please do this:

1. Cut/paste the output of this command:

rpm -qa *xulrun* *firefox* *mozilla* *flash* nsplugin*

2. Download and install debuginfo-install firefox

3. Then run firefox with a parameter -g.

That will start firefox running inside of gdb debugger. Then wait until the 100% CPU happens. When it does, you should go back to the gdb and interrupt with Ctrl-C. Then please run:

4. (gdb) thread apply all backtrace

All times are GMT -5. The time now is 09:45 AM.