LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Fedora (https://www.linuxquestions.org/questions/fedora-35/)
-   -   Firefox java plugin not working, please help. (https://www.linuxquestions.org/questions/fedora-35/firefox-java-plugin-not-working-please-help-163694/)

d3fault 03-29-2004 06:44 AM

Firefox java plugin not working, please help.
 
Hi, i use mozilla firefox 0.8, i downloaded the plugin, libjavaplugin_oji.so is in /plugins but it just doesn't do anything, webpages using java applets still ask me to download the plugin. It worked flawlessly on other distributions but not on fc1:confused:

Any ideas? Thx:)

mrcheeks 03-29-2004 06:59 AM

you downloaded the plugin, but you don't have java installed.

it is like having the plugin for windows media player without windows media player installed.

d3fault 03-29-2004 07:05 AM

Sorry i didn't mention it but I installet j2re using apt-get, what should i do?

anttieskola 04-15-2004 05:42 AM

Java plugin Mozilla
 
I have always downloaded Java SDK from java.sun.com, but you can download also JRE only if you dont develop java code.
Then chmod +x to the j2...bin file and execute it it will self extract then move it to some location then make environment variables to the profile. i use /etc/profile.d/ dir and make there java.sh file that is executable and readable to all.
Content of java.sh:
export JAVA_HOME="/opt/j2sdk1.4.2_04"
export JAVA_PATH="$JAVA_HOME"
export PATH="$PATH:$JAVA_HOME/bin"
Then make a symbolic link to the /usr/lib/mozilla/plugins folder like this:
ln -s /opt/j2sdk1.4.2_04/jre/plugin/i386/ns610-gcc32/libjavaplugin_oji.so /usr/lib/mozilla/plugins/libjavaplugin_oji.so

Where first is the plugin (target) second argument is the mozilla plugins folder.
Restart mozilla and it works :D

I use Fedora core test release....

Magus67 04-16-2004 11:59 AM

use this faq for more plugins
http://plugindoc.mozdev.org/faqs/firefox-linux.html

goldfish1 04-22-2004 08:36 AM

workaround
 
http://bugzilla.mozilla.org/show_bug.cgi?id=239366#c11

number9 05-21-2004 03:21 AM

If you are using SuSE 9.1 and selected Java during the installation, you get two versions with three plugins. Use the following to have FireFox 0.8 take the right one::

Navigate to your Mozilla Firefox plugins directory, and issue the following command:

ln -s /usr/lib/java/jre/plugin/i386/ns610-gcc32/libjavaplugin_oji.so

------------------------------------------------------------
When was the last time you donated to Open Source?

pf1359 05-22-2004 01:55 AM

I have SuSE 9.1, and I installed Firefox 0.8 using the YaST installer. I finally got Java working, so I thought I'd post how I did it:

The file I wanted to link was /usr/lib/java/jre/plugin/i386/ns610-gcc32/libjavaplugin_oji.so

The directory SuSE uses for plugins is in /opt/MozillaFirefox/lib/plugins/java2/plugin/i386.

There was no directory for ns610-gcc32, so I created one. I then used ln-s to create a symlink to the .so file. Java now works for me.

cmgleipzig 07-10-2004 11:16 AM

Can you clarify further
 
I realize that the last post here was in May, but perhaps someone will look here. I'm having the same trouble getting Java to work. Can you or someone clarify what/where you're creating the ns610-gcc32 directory? I'm using SuSE 8.2, not 9.1, but I'm guessing our problems are similar. Thanks.

CeltiKaos 07-27-2004 10:49 AM

Re: Can you clarify further
 
Quote:

Originally posted by cmgleipzig
I realize that the last post here was in May, but perhaps someone will look here. I'm having the same trouble getting Java to work. Can you or someone clarify what/where you're creating the ns610-gcc32 directory? I'm using SuSE 8.2, not 9.1, but I'm guessing our problems are similar. Thanks.
I'm using Mandrake 9.1 and 10 (two machines). Java works on neither of them. I do have the ns610... file. Where did you put it to make this work? :)

Thanks,

Julian

invasian 08-06-2004 10:18 AM

Hey...just wanted to add something here if someone can figure this out...i have suse 9.1...i installed the plugins into /usr/lib/browser-plugins ...with konqueror, java works, but with firefox, it does not. the reason why i have libjavaplugin_oji.so in there is because that is where the flashplayer plugins were installed....flash works in firefox and it is an option to enable/disable in the firefox preferences, but java is not...this is so frustrating, cause i feel i'm almost there....


EUREKA...just to let you know it finally worked...apparently /usr/lib/browser-plugins is for konqueror....there was another folder /home/invasian/.mozilla/plugins (invasian is my username) where the mozilla plugins should go to...i knew this, but couldn't find it before...anyways, make sure you link to libjavaplugin_oji.so, otherwise firefox crashes. good luck


All times are GMT -5. The time now is 10:32 AM.