-   Fedora (
-   -   Fedup Failed (

mickeyboa 02-18-2013 06:32 PM

F17 > F18 Failed.

It went to the REBOOT and started upgrade but after upgrade complete it would only boot into F17 and would go to the login , can't login as user or root, it comes back to the login each time after entering user name and password.

[MODERATION]Please see contents after merge below:[/MODERATION]

Running fedup from F17 to upgrade to F18, Is this the correct procedure ?

All I have is a live-dvd-KDE.iso, how can I find a iso that will let me upgrade my KDE desktop.

And I get the below Error message.

# fedup-cli --iso /home/jim/Downloads/Fedora-18-i686-Live-KDE.iso --debuglog=fedupdebug.log
setting up repos...
Error: can't get boot images.
The 'fedupiso' repo was rejected by yum as invalid.

This the only thing in /var/log/messages when fedup-cli is run;

Feb 18 18:50:47 localhost dbus[581]: [system] Activating service name='net.reactivated.Fprint' (using servicehelper)
Feb 18 18:50:47 localhost dbus-daemon[581]: Launching FprintObject
Feb 18 18:50:47 localhost dbus-daemon[581]: dbus[581]: [system] Successfully activated service 'net.reactivated.Fprint'
Feb 18 18:50:47 localhost dbus[581]: [system] Successfully activated service 'net.reactivated.Fprint'
Feb 18 18:50:47 localhost dbus-daemon[581]: ** Message: D-Bus service launched with name: net.reactivated.Fprint
Feb 18 18:50:47 ost dbus-daemon[581]: ** Message: No devices in use, exit

amani 02-19-2013 11:59 AM

Post system specs
update logs

or file bug directly at redhat bugzilla.

Try to boot into runlevel 2 in rw mode and complete yum transactions.

Glennzo 03-08-2013 03:31 AM

Why are you using an ISO file, no Internet during upgrade? I've had success twice with the command with an Internet connection.

sudo fedup-cli --network 18 --debuglog fedupdebug.log
I'm using Gnome / Cinnamon.

svarmido 05-28-2013 09:41 AM

How I successfully completed upgrade - Fedora 17 to 18.
Steps I used to achieve a successful fedup upgrade from Fedora 17 to 18.

'yum --enablerepo=updates-testing install fedup'

Enabled the new grub2 boot scheme.

'grub2-install /dev/sda'
'grub2-mkconfig -o /boot/grub2/grub.cfg'
'ln -sf /boot/grub2/grub.cfg /etc/grub2.cfgtes clean metadata'

Started the upgrade:

fedup-cli --network 18

The files downloaded successfully to /var/tmp/fedora-upgrade.
I rebooted and selected the Upgrade option. But, the upgrade failed at the scanning stage, dropping me into a shell. Options were continue with Ctrl-D, or log in as root for maintenance. Logging in as root, mounting partitions and then exiting the shell did not resume the upgrade. But, fortunately the boot process continued using the Fedora 17 kernel. I was able to login and achieve the desktop.

Determined to avoid starting over from scratch, I opened a terminal, logged in as root and used yum to get the downloaded Fedora 18 files installed and Fedora 17 files removed.

Tried the commands below that returned errors reporting version mis-matches.

yum upgrade /var/tmp/fedora-upgrade/*/*/*
yum upgrade /var/tmp/fedora-upgrade/*/*/* --skip-broken

Resolved the mis-matches with the commands below.

'yum install /var/tmp/fedora-upgrade/updates/packages/xorg-x11-server-Xorg xorg-x11-drv-evdev xorg-x11-drv-vesa'
'yum install /var/tmp/fedora-upgrade/updates/packages/glibc*'
'yum install /var/tmp/fedora-upgrade/updates/packages/redhat-lsb*'
'yum install /var/tmp/fedora-upgrade/default-installrepo/packages/libgcc*'

'yum distro-sync'

To ensure latest version of grub is installed:

'yum install grub'

Enabled the new grub2 boot scheme again...

'grub2-install /dev/sda'
'grub2-mkconfig -o /boot/grub2/grub.cfg'
'ln -sf /boot/grub2/grub.cfg /etc/grub2.cfgtes clean metadata'

Rebooted - got boot loop using the Fedora 18 kernel.

Rebooted, and for the heck of it chose the upgrade option.
Wala! The upgrade process completed successfully - but still had boot loop when rebooting.

'grub2-editenv list'

Revealed Fedora 17 kernel was still the default.

Searched internet for possible resolution and discovered additional steps to perform:
'grub2-set-default 'Fedora Linux, with Linux 3.9.4-200.fc18.x86_64''

'grub2-editenv list'

Now returned: saved_entry=Fedora Linux, with Linux 3.9.4-200.fc18.x86_64

'grep ^menuentry /boot/grub2/grub.cfg | cut -d "'" -f2'

Returned: Fedora

With upgrade now apparently successful I rebooted but mouse pad did not work.

Internet search suggested I was missing synaptics... Probably used yum to remove due to a reported conflict...

yum install xorg-x11-drv-synaptics

Rebooted and everything appears to be working o.k. now.


amani 06-05-2013 09:02 AM

So Fedup really needs to be fixed.

svarmido 06-16-2013 07:49 AM

Although I have not gone back and tried this, odds are good adding a step after the update files successfully download will lead to a successful, problem free update.

'yum --enablerepo=updates-testing install fedup'

Enable the new grub2 boot scheme.

'grub2-install /dev/sda'
'grub2-mkconfig -o /boot/grub2/grub.cfg'
'ln -sf /boot/grub2/grub.cfg /etc/grub2.cfgtes clean metadata'

Start the upgrade:

fedup-cli --network 18

Once all files have successfully downloaded perform the following steps.

Before rebooting into the Upgrade I'd recommend the following:

Open a console/terminal.
Log in as root.
Change to the file system where the update files have downloaded to. This file system no longer exists on my laptop post upgrade, so you'll have to locate it yourself. I am guessing, but it may have been in /var/tmp/ .

then at the prompt:

'yum install ./<kernel-name> to make certain the Fedora 18 kernel is installed before rebooting. You may encounter error messages informing you of missing dependencies or conflicts. All I can say is try to resolve these issues before rebooting into the Upgrade option.

Check to see which kernel version is set to boot:

'grub2-editenv list'

If Fedora 17 kernel is still the default:

'grub2-set-default 'Fedora Linux, with Linux 3.9.4-200.fc18.x86_64'

'grub2-editenv list'

Desired output: saved_entry=Fedora Linux, with Linux 3.9.4-200.fc18.x86_64

'grep ^menuentry /boot/grub2/grub.cfg | cut -d "'" -f2'

Desired output: Fedora

Reboot and select Upgrade option. Upgrade should complete successfully.


svarmido 06-18-2013 12:17 PM

Moved content into last post

All times are GMT -5. The time now is 09:02 AM.