LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices


Reply
  Search this Thread
Old 11-09-2003, 09:27 AM   #1
serquicia
LQ Newbie
 
Registered: Dec 2002
Location: Argentina
Distribution: Fedora Core 1
Posts: 15

Rep: Reputation: 0
Fedora - -Mount fat32 partition


I've been trying to mount a partition adding the corresponding line to /etc/fstab.

The problem is that each time I reboot the line disappears. Is there any other place where I should add the mount options?

Thanks
 
Old 11-09-2003, 05:09 PM   #2
contra
LQ Newbie
 
Registered: Nov 2003
Posts: 11

Rep: Reputation: 0
are you sure you saved the file? that sounds dumb but its a possibility
 
Old 11-09-2003, 05:20 PM   #3
xconspirisist
Member
 
Registered: Dec 2002
Location: United Kingdom
Distribution: Ubuntu
Posts: 276

Rep: Reputation: 30
are you root ?
 
Old 11-09-2003, 05:22 PM   #4
serquicia
LQ Newbie
 
Registered: Dec 2002
Location: Argentina
Distribution: Fedora Core 1
Posts: 15

Original Poster
Rep: Reputation: 0
I did everything as root (su) and yes, I did save the file. I know because after doind that I just mounted the partition.
 
Old 11-10-2003, 09:26 AM   #5
nano
LQ Newbie
 
Registered: Nov 2003
Location: Mx!!!
Distribution: Fedora Core 2
Posts: 10

Rep: Reputation: 0
Maybe you write something wrong in the file.

What "says" your line where you mount the fat32?

I'm write that because something like that happen to me when i try to get the usb flash drive to work.
 
Old 11-10-2003, 10:59 AM   #6
serquicia
LQ Newbie
 
Registered: Dec 2002
Location: Argentina
Distribution: Fedora Core 1
Posts: 15

Original Poster
Rep: Reputation: 0
The problem is that the line is gone now. I think that some boot process just writes the file everytime, but that was not happening with RH9.

Tomorrow I'll try again (I'm not at my pc right now)
 
Old 11-10-2003, 09:52 PM   #7
edawad
LQ Newbie
 
Registered: Oct 2003
Location: UCSD
Distribution: Debian
Posts: 29

Rep: Reputation: 15
Hi,

I get the same problem. I have

/dev/hdb5 /mnt/winF vfat auto,users 0 0

But everytime I reboot it seems to revert to default, and my winF folder is gone.
 
Old 11-10-2003, 11:00 PM   #8
mishmash
Member
 
Registered: Nov 2003
Location: Canada
Distribution: Mandrake 9.x, 10
Posts: 87

Rep: Reputation: 15
Hi,

The following is the line I use in the /etc/fstab file and it works great:

/dev/hda1 /mnt/windows vfat auto,utf8,umask=0 0 0

Please note that the "utf8" option is to make sure that the french/spanish type of characters are displayed/handled correctly by the file system. You do not need this option if you only have english characters.

Give it a try!

Regards,

mishmash
 
Old 11-11-2003, 05:52 PM   #9
kevred
LQ Newbie
 
Registered: Aug 2003
Location: new zealand
Posts: 5

Rep: Reputation: 0
with some linux distros you have to move to the end of your line in fstab then hit the spacebar then save try this
if the directory disappears on reboot it maynot be correctly made ..try from a console under root:
mkdir /mnt/winF
then link this to your device with
ln -s /dev/hdb5 /mnt/winF
add your line to fstab and try again.
Hope this helps
 
Old 11-13-2003, 01:54 AM   #10
bshelton
Member
 
Registered: Sep 2003
Location: Fairfax, VA
Distribution: RedHat/Fedora/Mandrake/BSD/Solaris
Posts: 54

Rep: Reputation: 15
if you guys can't get anything else to work, you might want to try this line in the /etc/fstab

/dev/hda1 /mnt/WinFAT32 vfat auto,umask=000 1 0

Hope this helps out some.
 
Old 11-22-2003, 01:56 PM   #11
serquicia
LQ Newbie
 
Registered: Dec 2002
Location: Argentina
Distribution: Fedora Core 1
Posts: 15

Original Poster
Rep: Reputation: 0
I'm using this line:

/dev/hda5 /mnt/win_e vfat auto,utf8,umask=0 0 0

and added some empty lines below that and now everything is working
 
Old 11-22-2003, 02:31 PM   #12
mishmash
Member
 
Registered: Nov 2003
Location: Canada
Distribution: Mandrake 9.x, 10
Posts: 87

Rep: Reputation: 15
Very Good!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to format to FAT32, and how to mount my FAT32 partition. bonniehandi Linux - Newbie 16 03-05-2006 08:54 PM
Fedora core 3 mount windows FAT32 partition device busy starney Fedora 4 11-30-2004 10:08 PM
can't mount fat32 partition warpengi Slackware - Installation 6 09-17-2004 04:56 PM
Can't mount FAT32 partition EcceVery Debian 5 09-13-2004 06:53 AM
How to mount a new fat32 partition IceOnly Linux - Software 2 06-11-2003 02:10 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora

All times are GMT -5. The time now is 03:40 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration