-   Fedora (
-   -   Fedora first update hangs on "Fetching rpm header: glibc-2.3.2-101.4" (

Darthomir 03-15-2004 10:36 AM

Fedora first update hangs on "Fetching rpm header: glibc-2.3.2-101.4"
Hello. I just activated my Internet connection that I get a message saying I have 75 updates available! So they tell me to connect to the Red Hat Network, I download "the new key" and so on, I click Ok (I let everything by default) there are two channels for the update, ok so I launch up2date but after a while, it hangs on "Fetching rpm header: glibc-2.3.2-101.4".
Can anyone help me!? It would be appreciated! Thx,

THX75 03-15-2004 11:01 AM

It's most likely because you're using the "stock" Redhat Network settings and are trying to download the updates from Redhat, which can be slow as hell! It will take forever to update your system using the Redhat server. There's some articles at that will show you how to speedup up2date by editing the server list to use mirrors.

I use "yum" to update my installation of Fedora. There's instructions to speed it up to.


noeffred 03-15-2004 11:08 AM

you should use a mirror such as

redhats servers tend to let the clients hang forever. nasty behavior, have to admit that.

Bomb187 03-15-2004 11:27 AM

I had the same problem. iIt was downloading slow, but i disconnected and re downloaded, and the speeds were fine. but the hang does happen. ill try giving that link a try.

Darthomir 03-15-2004 12:14 PM

Ok thanks alot because i was downloading at 10 kb.. takes forever! thx, ill try these links!

Darthomir 03-15-2004 01:03 PM

OK I found that webpage telling me how to setup a mirror. I found my mirror, i wanna use yum or whatever but when they say I have to change the yum.conf file, its in readonly mode. I even logon as root, did a chmod ug+rw but no changes.. still in readonly mode. How can I access this file to change the baseurl in order to put my mirror? Thx alot,

noeffred 03-15-2004 01:11 PM

If you're root, you should be able to overwrite the file no matter what. You sure you're logged in as root?

Darthomir 03-15-2004 01:54 PM

Ok thx.. that was stupid though!
Is there a gui interface than typing #yup ... ?
Thx alot

Darthomir 03-15-2004 02:06 PM

Ok I try with the mirrors list there but none of them seems to work (I tried like 10 of them). I first type #yup check_update
then I can get:
retrygrab() failed for..
failover: out of servers to try..
550 headers: no such file / directory
is it the right way to use yum?

THX75 03-15-2004 03:50 PM

yum check-update

Additional Info

Here are the servers from my yum.conf

name=Fedora Core $releasever - $basearch - Base

name=Fedora Core $releasever - $basearch - Released Updates

Darthomir 03-15-2004 04:03 PM

Ok thx I'll try that in an hour.

Darthomir 03-15-2004 05:06 PM

Once I have the headers, what do I do? I'm not going to install them one by one right? Do I type #yum update ? Or something else?
Btw, thx for your yum config, it works fine!

THX75 03-15-2004 09:46 PM

If you want to install all of the updates available for your installation, then you type "yum update". It should be okay to update everything at once.

I'd probably reboot after updating everything the first time because there's some updates to the xwindows.

You can also update by package or use wildcards. ie.) yum update xfree86*

Have fun!

- THX75

Darthomir 03-16-2004 09:22 AM

Ok thanks for the info.
I am trying to do the update this morning but it does not work: i get a 404 not found error when I do #yum update. Same error if I do again #yum check-update. I suppose the servers (all of them!??) are down? I have the same yum.conf as THX75.
I found some info there but it does not help more.
Thx for the help again,

Darthomir 03-16-2004 06:05 PM

Ok.. now I just forgot about the yum.. and I used redhat network instead.. did some updates (along with the new yum version yah..) but thats it, the yum update has a "not valid key" so ok, skip that update. But when I did install these updates, it did try to install the yum update. So I got an error and everything start hanging. I press power off since I cannot do anything, then now when I reboot under linux I have no more GUI, even after pressing Y for the "disk check" I suppose. So ok I can connect, but under a "terminal" form, no more GUI, no more browser for Internet! AH!! How can I get these things back!! :-)
Thx alot,

AND oh, just before I log in (i have to type enter first) i get this message:
Id "x" respawning too fast: disabled for 5 minutes

All times are GMT -5. The time now is 12:20 PM.