-   Fedora (
-   -   Fedora Core Unable to boot up! (

orionteo 10-04-2007 04:40 AM

Fedora Core Unable to boot up!

I have a qns for the expert here.

I have a 80Gb IDE harddisk which contain Fedora Core 6 which i want to clone to a 250Gb SATA harddisk. After using dd if=/dev/hda of=/dev/sda, I manage to boot up until:

Uncompressing Linux .... ok, booting the kernel
Reading all physical volume. This may take a while ...
No volume group found
Volume group "VolGroup00" not found
Unable to acess resume device (/dev/VolGroup00/LogVol01)
Mount: could not find filesystem '/dev/root'

However when i use lvscan and pvscan, it shows something. Does anyone know how to resolve this problem?



orionteo 10-04-2007 04:51 AM

Just to add:

I have tried adding in the kernel

root=/dev/VolGroup00/LogVol00 pci=nommconf rhgb quiet all-generic-ide \boot

But still have the same problem.

Please advice.. i am a very newbie to linux

Many many thanks!

shafty023 10-04-2007 12:55 PM

So you did a straight dd copy over to a larger hard drive? I'd imagine you'd run into issues with variances in partition sizes seeing as how the new hdd will have extra free space that LVM didn't see before in its config files. My recommendation is just to install fedora 7 on the new drive and copy over your needed data files to the new hdd once booted up. Of course you may want to stick to your game plan and not have to reinstall all those apps but I don't think it'll be as easy as using dd.

Have you tried booting from a fedora core 6 rescue disk and running /sbin/fdisk to view the partition table? Just to make sure that things aren't all out of whack now.

orionteo 10-05-2007 03:27 AM

Yah i have done it. It shows the partition exactly the same as old harddisk.

I believe it has to do with the initrd etc etc because of the different in device (PATA to SATA). However i do not know how to reload this initrd......

shafty023 10-05-2007 09:42 AM

It could be different device names stemming from PATA to SATA. You could always create the partitions on the new hdd first and then copy the data over using cpio rather than using dd on the whole drive. That might work better for you. So blow away the new hdd by whacking the partitions, redo it with or without LVM and then copy / using "find / | cpio -pdmuv /path/to/new/hdd". Of course to do that you'll need to partition the new hdd, then create a filesystem on it using mkfs.ext3, then mount it somewhere while ur booted in linux and then u can use that cpio command to copy over the data

All times are GMT -5. The time now is 05:00 PM.