-   Fedora (
-   -   fedora core 3 64 bit install issues (

sturla 05-06-2005 05:00 PM

fedora core 3 64 bit install issues
asus a8n nforce 4 main board
pci-e geforce 6600
sata II
amd 64 +

Having trouble installing FC3 64 on this system. I can't get the graphical installation to work, so I've installed it in text mode. Things went well until i was finished reading the disks. When I restarted to finish the installation the screen went unreadable. Just some crazy graphics.

I have tried to boot from the installation disk, so that I could get to the command line (recovery mode). I had a disk burned with nforce 4 driver and Geforce driver from Nvidia. The latest. But in recovery mode i can't find the cdrom in /dev. It's not there. And I can't get to it.

Can someone help?

deadbug 05-09-2005 08:18 PM

You can try this
Our systems are a little different, but I had what sounds like the same problem. The only solution that I could get to work was changing the number of colors on one of the final configuration screens. I think it is the next to last one where it verifies the monitor and video card, the screen resolution and number of colors. I changed the third one from "Millions of Colors" to "256 Colors" and got everything to work.

My problem is the less than sterling driver Fedora includes for my video card. To get back to the "Millions of Colors" involves searching this board for your video card and finding a way to install a better driver.

Good luck

Crasherz 05-11-2005 08:52 PM

I installed core 3 on a ABIT AN8 fatal1ty. The install went fine, all in graphical mode. However I experienced the same problem at reboot with the screen just scrambled. It seemed to have problems because there are no PCI slots (this is a PCI express board). I have no resolution as yet but I will try to install with reduced graphics config and then update the nvidia drivers.

YNGenetics 05-23-2005 08:27 AM

RH3 x86_64/NVIDIA display & PCI problems
Thanks to all of you for your posts on the RH3 x86_64/NVIDIA display
problem. I wanted to describe my experiences with this problem in the
hopes that others may find it helpful, since I encountered a number of
additional problems on my system that I've mostly been able to handle,
but a few problems remain.

Here's my system:
AMD Athlon 64 3500+
CORSAIR 1GB (2 x 512MB) 184-Pin DDR SDRAM DDR 400 (PC 3200) x 2 (2 GB total)
Western Digital Raptor 73GB Serial ATA150 Hard Drive
GIGABYTE GV-NX57128D Geforce PCX5750 128MB 128-bit DDR PCI-Express x16 Video Card
MSI K8N Neo4 Platinum Socket 939 NVIDIA nForce4 Ultra Motherboard
Pioneer DVR-109 IDE DVD Burner

Here's what I did:

1. Clean install of FC3 x86_64
(on graphical boot, fonts and graphics are totally illegible, as described by
others on this thread)

2. Rebooted, editing GRUB on startup (removed 'rhgb' and 'quiet' and
added "3" to end of line) and on the shell typed:
rpm --import /usr/share/rhn/RPM-GPG-KEY
rpm --import /usr/share/rhn/RPM-GPG-KEY-fedora
yum check-update
yum update

3. Now I got a number of conflicts with a component of PERL. To solve this,
I deleted PERL (both the 32 and 64 bit versions) and reinstalled them:

rpm -e --allmatches --nodeps perl
yum -y install perl
yum update

(Now everything worked fine, the system updated)

4. Rebooted with the new kernel 2.6.10-1.770
(Graphical boot worked now, but was low-res)

5. Downloaded and

6. Rebooted, edited GRUB on startup (removed 'rhgb' and 'quiet' and
added "3" to end of line).

7. Installed the NFORCE drivers and followed the prompts.

8. Installed the NVIDIA driver and followed the prompts.

9. Edited the "/etc/yum.repos.d/fedora-devel.repo"
enable=0 changed to enable=1

10. Updated xorg packages:
yum check-update >out
cat out|grep xorg
yum update <each package listed from above>

11. Edited xorg.conf
Replaced "driver vesa" with "driver nvidia"
Confirmed that "load glx" was present in "module" section
Confirmed that "load dri" was present in the "module" section.

12. Rebooted
Now I saw the NVIDIA splash screen.

13. Edited /etc/X11/xinit/xinitrc to load the settings on startup:
nvidia-settings --load-config-only &
. /etc/X11/xinit/xinitrc

14. Using the GUI, under "display" in "system settings"
set display to NVIDIA
set monitor to NEC Multisync 95
set resolution
set colors to millions of colors

15. Rebooted

Now everything worked great. I'm still getting two errors on startup however:

PCI: Cannot allocate resource region 0 of device 0000:03:00.0
PCI: Cannot allocate resource region 3 of device 0000:05:00.0

Does anyone have any thoughts on what these errors are?


nhusted 05-23-2005 12:47 PM

This should all be fixed with the next big upgrade of xorg. Currently the xorg that comes on the Fedora disk doesn't recognize the new nvidia graphics cards and the nv driver will not work with them. The vesa driver also seems to have issues thus I always boot into rescue mode and fix the xorg config before booting into fedora proper.

All times are GMT -5. The time now is 11:27 PM.