LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Fedora (https://www.linuxquestions.org/questions/fedora-35/)
-   -   Fedora Core 2 test 3 missing header files (https://www.linuxquestions.org/questions/fedora-35/fedora-core-2-test-3-missing-header-files-181933/)

WingNut 05-15-2004 11:19 PM

Fedora Core 2 test 3 missing header files
 
Just installed Fedora Core 2 Test 3 on a buddies box. We tried to install the Nvidia video drivers. Nvidia installer complains that it cannot find kernel header files and specifies the file "modversions.h". My friend checked the box to install kernel sources during install.

Has anyone had and fixed this problem?

Much thanks in advance.

jale2ice 05-16-2004 10:09 PM

WingNut, There is an issue with the kernel that comes with FC2t3 and the nvidia drivers. You would have to recompile a kernel from kernel.org (so, that's what I've been reading). I tried it and it worked.

I saw a few threads here about it. Good luck!

WingNut 05-16-2004 10:49 PM

Thanks a million! I'll give that a shot and post the results.

bglnelissen 06-11-2004 03:14 PM

I copy past this, just found it. Good luck with it. It seems to work.

greetz Bas



the kernel being used has the

4KSTACKS=y

Built in.

Here is what i did to get nvidia working.

**Note, if you can ssh to your box than you could just edit your /etc/inittab to refelect 3 instead of 5 and then boot it back up or change your "nvidia" in xorg.conf to "nv" and boot back up. If you can't get to your box through ssh you might as well re-install since there was nothing on it.

Ok, back to the how to:

1.) su -

2.) cd /usr/src

3.) wget http://www.kernel.org/pub/linux/kern...-2.6.6.tar.bz2


4.) tar -xvjpf linux-2.6.6.tar.bz2

5.) cp /usr/src/linux-2.6.5-1.358/configs/kernel-2.6.5-i686.config /usr/src/linux-2.6.6/.config

After step 5 you need to
cd /usr/src/linux-2.6.6
then you can do
make oldconfig

6.) cd /usr/src/linux-2.6.6 && make oldconfig

VERY IMPORTANT!!!!
*** Anser "NO" to 4KSTACKS question and pretty much the rest of them.

7.a) make && make modules_install && make install

OR

7.b) make rpm
#rpm -ivh rpm -ivh /usr/src/redhat/RPMS/i386/kernel-2.6.6-1.i386.rpm


8.) vi /etc/inittab
*edit the runlevel to "3" instead of "5"

9.) cd /tmp

10.) wget http://download.nvidia.com/XFree86/L...-5336-pkg1.run

11.) reboot (chosse 2.6.6)

you should then be at a login prompt without graphical

12.) login as root

13.) sh /tmp/NVIDIA-Linux-x86-1.0-5336-pkg1.run

14.) vi /etc/X11/xorg.conf
!!change "nv" to "nvidia" , also comment out #"dri"

15.) modprobe nvidia

16.) telinit 5


Login as user and welcome in the goodness of 3d nvidia and the latest kernel.

Out!


All times are GMT -5. The time now is 10:38 AM.