-   Fedora (
-   -   Fedora boot errors after disk change over (

MrJoshua 02-06-2004 10:37 AM

Fedora boot errors after disk change over
I have a machine that was setup with an IDE install on hda. I purchased an SATA drive, to put on my MSIKT600 board. I copied over the filesystem, edited my fstab, and ran grub-install on the sda drive. I also made sure that my grub.conf file was not the problem, by passing the grub commands manually.

Well grub loads fine, and it extracts my kernel fine, but right at the point where it starts the init it fails with "Warning unable to open initial console". Now this error was not the first one with this setup. Before this I was getting pivot.root errors. I remade the initrd, and the pivot root stuff worked fine then, but now I am getting this problem. I then chrooted the sda fs and reinstalled the kernel, I still get the same error.

Does anyone have any idea's or suggestions. Has anyone else done this type of setup (copying ide install to sda device) and have some suggestions or tips for getting to work correctly. I searched the threads and the web, and really did not find very helpful information.



jailbait 02-06-2004 06:40 PM

"Warning unable to open initial console".

One strong possibility is that you have ownership and/or permissions screwed up on /dev/tty*. When you did the copy did you preserve permissions and ownership or did everything end up belonging to user root and group root? In particular check the group ownership on the /dev/tty* files. the group names should be a mixture of names. If they are all root then you have found the problem.

Be prepared. Create a LifeBoat CD.

Steve Stites

MrJoshua 02-07-2004 10:14 AM

That is what the problem ended up being. When I moved over the contents of /dev, I did a cp -pRA. I went back and used tar, and it works beautifully. Thanks for the help.

All times are GMT -5. The time now is 11:46 AM.