LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices


Reply
  Search this Thread
Old 10-04-2008, 09:50 PM   #1
CoppeRaven
LQ Newbie
 
Registered: Oct 2008
Distribution: Fedora 9
Posts: 3

Rep: Reputation: 0
Question Fedora 9 Update System Issue, Can anyone help?


This is what I get when I type "yum update" into the terminal and I have no clue why.

Quote:
Loaded plugins: refresh-packagekit
Setting up Update Process
Resolving Dependencies
--> Running transaction check
--> Processing Dependency: perl = 4:5.10.0-20.fc9 for package: perl-version
---> Package perl-Pod-Escapes.i386 1:1.04-34.fc9 set to be updated
---> Package samba-common.i386 0:3.2.3-0.20.fc9 set to be updated
---> Package perl.i386 4:5.10.0-34.fc9 set to be updated
---> Package perl-libs.i386 4:5.10.0-34.fc9 set to be updated
---> Package perl-Pod-Simple.i386 1:3.05-34.fc9 set to be updated
---> Package perl-Module-Pluggable.i386 1:3.60-34.fc9 set to be updated
--> Processing Dependency: samba-common = 3.2.0-1.pre3.9.fc9 for package: samba-winbind
--> Finished Dependency Resolution
samba-winbind-3.2.0-1.pre3.9.fc9.i386 from installed has depsolving problems
--> Missing Dependency: samba-common = 3.2.0-1.pre3.9.fc9 is needed by package samba-winbind-3.2.0-1.pre3.9.fc9.i386 (installed)
3:perl-version-0.74-20.fc9.i386 from installed has depsolving problems
--> Missing Dependency: perl = 4:5.10.0-20.fc9 is needed by package 3:perl-version-0.74-20.fc9.i386 (installed)
Error: Missing Dependency: samba-common = 3.2.0-1.pre3.9.fc9 is needed by package samba-winbind-3.2.0-1.pre3.9.fc9.i386 (installed)
Error: Missing Dependency: perl = 4:5.10.0-20.fc9 is needed by package 3:perl-version-0.74-20.fc9.i386 (installed)
I'm new to Fedora, though not new to linux. I've run Ubuntu, BackTrack, DSL, and others, but this is the first Fedora installation I've done. So far I like it other the this issue. Can someone please help me?
 
Old 10-04-2008, 10:08 PM   #2
billymayday
LQ Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
This type of thing happens every now and then - one package in a dependency chain gets updates, but another doesn't.

You can either wait a couple of days, or just exclude the problematic package.

try

yum update -x samba-common -x perl

(you may need to exclude more perl packages but try the above first)
 
Old 10-04-2008, 10:14 PM   #3
CoppeRaven
LQ Newbie
 
Registered: Oct 2008
Distribution: Fedora 9
Posts: 3

Original Poster
Rep: Reputation: 0
Thanks a ton, excluded them for now...Hopefully in a few days something will tweak that and let me install those updates.
 
Old 10-04-2008, 10:30 PM   #4
billymayday
LQ Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
If it takes more than a few days, you can add exclusions in /etc/yum.conf
 
Old 10-05-2008, 07:45 PM   #5
CoppeRaven
LQ Newbie
 
Registered: Oct 2008
Distribution: Fedora 9
Posts: 3

Original Poster
Rep: Reputation: 0
Great, thanks a ton man. You've been a big help.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
After Fedora Update System will not start carlos_duran Linux - Newbie 2 09-01-2008 02:38 PM
Fedora 9 Update System Issue captainxark Fedora 9 08-09-2008 09:57 PM
System update issue in Ubuntu 6.06 hallows1 Linux - Server 3 09-17-2007 02:19 AM
fedora 5 yum update fail and system crashed chlawren Linux - Software 0 07-26-2006 08:16 AM
Funny issue after x system update. pdeman2 SUSE / openSUSE 6 03-26-2006 05:06 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora

All times are GMT -5. The time now is 01:58 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration