LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices


Reply
  Search this Thread
Old 05-20-2008, 05:37 PM   #1
lcafiero
LQ Newbie
 
Registered: Apr 2007
Location: Felton, California, USA
Distribution: Korora
Posts: 9

Rep: Reputation: Disabled
Fedora 9 on PPC -- No GUI after install


Forgive me for asking a question that to most of you would probably be a routine digital grounder, but I just installed Fedora 9 on an iBook G3 (256MB RAM), and the install went well but when I rebooted I now have a black screen that says:

------------
Fedora release 9 (Sulphur)
Kernel 2.6.25-14-fc9.ppc on an ppc (tty1)

localhost login:
-------------

(without the -------)

And that's it.

A footnote of sorts: Anaconda wouldn't come up prior to installing, and there were messages on the bottom of the screen that said something about X having a problem getting started, which I suspect could be at the bottom of this.

When I run startx as root, I get this (and I'm transcribing it):

-start-

X.Org X Server 1.4.99.901 (1.5.0 RC 1)
Release Date: 5 September 2007
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.18-53.1.14.el5 ppc
Current Operating System: Linux localhost.localdomain 2.6.25-14.fc9.ppc #1 Thu May 1 05:51:33 EDT 2000 ppc
Build Date: 06 May 2008 03:28:46PM
Build ID: xorg-x11-server 1.4.99.901-29.20080415.fc9
Before reproting problems, check http://wiki.x.org #did that
to make sure that you have the latest version #did that
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting
(++) from command line, (!!) notice (II) informational
(WW) warning, (EE) error (NI) not implemented (??) unkonwn
(==) Log file: "/var/log/Xorg.0.log", Time May 20 21:26:15 2008
(==) Using config file: "/etc/X11/xorg.conf"
(EE) Unable to find a valid framebuffer device
(EE) R128(0): Failed to open framebuffer device, consult warnings and/or
errors above for possible reasons (you may have to look at the
server log to see the warnings)
(EE) Screen(s) found, but none have a usable configuration

Fatal server error:
no screens found
giving up.
xinit: Connection refused (errno 111): unable to connec to X server
xint: No such process (errno 3): Server error
[root@localhost -]
-end-

So what I'm getting from this is that there's a problem with the framebuffer device, and/or a screen may not have a usuable configuration. But from there I'm kind of lost.

If anyone could help, I would be grateful.

Thanks

Larry Cafiero

PS -- I have Fedora 9 working on a Dell Inspiron 5000 and it's working fine, but I need the PPC version to work for a presentation at an installfest on Friday.
 
Old 05-23-2008, 10:22 AM   #2
amdawi
Member
 
Registered: Sep 2003
Distribution: Fedora
Posts: 47

Rep: Reputation: 15
the same problem i have.
we need solution,

thanks,
 
Old 05-23-2008, 11:01 AM   #3
amdawi
Member
 
Registered: Sep 2003
Distribution: Fedora
Posts: 47

Rep: Reputation: 15
Just now , I found solution...

change xorg.conf -> xorg.conf.old
and restart ...
 
Old 05-23-2008, 02:54 PM   #4
amathuriya3
LQ Newbie
 
Registered: May 2008
Posts: 1

Rep: Reputation: 0
Thanks, it worked for me as well!
 
Old 06-01-2008, 06:41 AM   #5
motsteve
LQ Newbie
 
Registered: May 2008
Location: Plantation, FL
Distribution: Fedora 9 Suse11PPC MacOS10.5.5
Posts: 11

Rep: Reputation: 0
I hate to beat a dead horse, but I also had the same problem. The answer given told me to do a mv xorg.conf to xorg.conf.old. That seemed to work for two people, but maybe I misinterpreted the description of the fix. My install totally misses the xorg.conf file and gives me the error messages as described earlier. BTW, if the fix is to change an existing .old file to xorg.conf, I didn't have a xorg.conf.old file originally to edit. My subdirectory only had xorg.conf and locate could not find a xorg.conf.old.

Last edited by motsteve; 06-01-2008 at 06:45 AM.
 
Old 06-05-2008, 10:09 AM   #6
tcb
LQ Newbie
 
Registered: Jun 2008
Location: Sydney AU
Distribution: Various
Posts: 1

Rep: Reputation: 0
Had the same problem on an old Powerbook G4 Titanium (2001 vintage). Found the solution in RedHat's Bugzilla report 445419 < https://bugzilla.redhat.com/show_bug.cgi?id=445419 >.

In /etc/X11/xorg.conf, section "Device", change Driver to "fbdev" (instead of "r128" as it was originally in my case).

Note that the correct driver depends on your Mac model - see e.g. bug 155151 on the same site.
 
Old 06-06-2008, 05:29 AM   #7
motsteve
LQ Newbie
 
Registered: May 2008
Location: Plantation, FL
Distribution: Fedora 9 Suse11PPC MacOS10.5.5
Posts: 11

Rep: Reputation: 0
Quote:
Originally Posted by tcb View Post
Had the same problem on an old Powerbook G4 Titanium (2001 vintage). Found the solution in RedHat's Bugzilla report 445419 < https://bugzilla.redhat.com/show_bug.cgi?id=445419 >.

In /etc/X11/xorg.conf, section "Device", change Driver to "fbdev" (instead of "r128" as it was originally in my case).

Note that the correct driver depends on your Mac model - see e.g. bug 155151 on the same site.

That did the trick. FBDEVHW was not reading the framebuffer /dev/fb0 and I read the ati and r128 readme's and they said to do what was on the xorg.conf file I had. The driver for r128 did need updating, but the update did the same thing. They need to fix this in the Fedora camp because there are many Rage128 cards out there in ppc's and many people are probably right now as baffled as I was. Thank you very much for your fix, it is greatly appreciated.

BTW, executing Xorg -configure produced a xorg.conf which was giving the same error. r128 may have to be changed.

Steve
 
Old 09-07-2008, 06:26 PM   #8
buzzybee73
LQ Newbie
 
Registered: Nov 2006
Posts: 6

Rep: Reputation: 0
Unhappy No GUI in Fedora 9

Quote:
Originally Posted by amdawi View Post
Just now , I found solution...

change xorg.conf -> xorg.conf.old
and restart ...
Hey Guys,

I have a Mac G3 Bondai Blue, slot loader which I have just installed Fedora 9.0.

I can only get it to boot in text mode.

Sounds like "lcafiero" and "amdawi" are having the same problem, but Unlike these two users, i dont understand how to fix it, please help!!

I am a windows geek, but I'm a bit slow when it comes to linux, so step by step instructions would be much appreciated

Cheers

Buzz
 
Old 09-08-2008, 08:47 AM   #9
motsteve
LQ Newbie
 
Registered: May 2008
Location: Plantation, FL
Distribution: Fedora 9 Suse11PPC MacOS10.5.5
Posts: 11

Rep: Reputation: 0
Quote:
Originally Posted by buzzybee73 View Post
Hey Guys,

I have a Mac G3 Bondai Blue, slot loader which I have just installed Fedora 9.0.

I can only get it to boot in text mode.

Sounds like "lcafiero" and "amdawi" are having the same problem, but Unlike these two users, i dont understand how to fix it, please help!!

I am a windows geek, but I'm a bit slow when it comes to linux, so step by step instructions would be much appreciated

Cheers

Buzz
Welcome to Linux. The box you are putting Fedora on is very tiny, but let's try to make it work anyway. Your xorg.conf file is the set up file to configure X windows. X windows provides all your graphical user interfaces at the desktop level. When your xorg.conf file is messed up, your graphical user interface is messed up, it is as simple as that. In the xorg.conf file are text statements which are very readable. This particular file is set up in sections, each of which defines what kind of mouse you have, what your monitor is, how the keyboard is configured etc.

Because of your situation, you will have to use the text mode of Linux. Don't get scared, it's not that bad. I want to help you with some of the basics, but I can only get so basic before this post becomes a book. If you have access to the internet (and apparently you do), I would recommend looking around and finding the tutorials on using the terminal and how to use the editors while in the terminal to modify files because Linux is all about text files. One place to start in learning detailed basics is:

http://rute.2038bug.com/node1.html.gz

There is a place, though, that has loads of links to all things Linux:

http://loll.sourceforge.net/linux/links/

In the meantime lets gloss over what you need to do to fix your problem. This is just to point out the big parts so that you can go and look up the specifics to get you started. When you have the text window in front of you when you first boot, you will be at the login prompt. I don't remember how Fedora installs, but if you inputted a user name and password, just use those to log in. If it was root, use root. The stuff you have to do requires root, but you can use sudo for this if you installed as user. When you get the : prompt you are now ready to start issuing commands to the system. To let you see your xorg.conf file and get a feel for it, type "less /etc/X11/xorg.conf. (The x back there is capital.) You'll get a screen full of text. The lines starting with # are the comment lines and they provide a lot of useful information in them, so read those. You can navigate the normal way with the arrow keys and you can go up a screen at a time by hitting the space key. To go back a page at a time use the page up/page down buttons. The section of interest to you will look like this:

Section "Device"
Identifier "ATI Technologies Inc Rage 128 PF/PRO AGP 4x TMDS"
Driver "ati"
BusID "PCI:0:16:0"
Option "UseFBDev" "true"
EndSection


Your machine has a ATI Rage IIc (Rev. A) or Rage Pro (Rev. B). I don't know which you might have, but you would have to use your system profiler to tell you, if you still have MacOS on your machine. You can do some searching around on the web to find out what to use as the driver for your video as this is most likely what is wrong with the xorg.conf. Read the file that is described in the error message to make sure what is causing your "error". Don't worry too much about "warnings".

To edit the file you'll have to learn how to use vi or nano or one of the other editors, but it won't take long just to learn enough basics to do what you want to do.

Getting back to where you are in the xorg.conf file, to get out of the look around mode, just push q for quit and you're back to your : prompt.

Ultimately you will need to something like "sudo vi /etc/xorg.conf" to edit the file, but before you do, make a backup copy of the xorg.conf file using the command "cp -p /etc/xorg.conf /etc/whateveryoulike.bak" just in case you completely screw up the xorg.conf file. Once you get your xorg.conf file fixed you'll want to try out the new one. Just do a command "startx" and it will either go into the graphics mode or will return you an error. If you get the error, it will tell you where to look for the details. Use less again to go there and look.

If you just want to restart everything and you are at the : prompt, type "reboot". Things aren't instantaneous so bear with it and the machine will do a restart.

I hope this will get you started. If you have any questions, just come back here and ask.
 
Old 10-07-2008, 06:48 PM   #10
buzzybee73
LQ Newbie
 
Registered: Nov 2006
Posts: 6

Rep: Reputation: 0
Hey MotSteve....

First of all, sorry for being so slow to respond, i've been uber-busy, but thats no excuse for my rudeness, and thanks for a bullet fast reply

Anyway, I tried what you said, and I got, and I got this..

Section "Device"
Identifier "Videocard0"
Driver "r128"
Option "UseFBDev" "true"


and when I typed "startx", it said, amongst other pointless instructions,
as shown,

(==)Log file: "/var/log/Xorg.0.log"
(==)Using config file: "/etc/X11/xorg.conf"
(EE) Unable to find a valid framebuffer device
(EE) R128(0): Failed to open framebuffer device, consult warnings for possible reasons.
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found
giving up.
xinit: Connection refused (errno111): unable to connect to X server
xinit: No such process (errno 3): Server error

Hope this may help, I have not changed any settings

Buzz
 
Old 10-08-2008, 06:18 AM   #11
motsteve
LQ Newbie
 
Registered: May 2008
Location: Plantation, FL
Distribution: Fedora 9 Suse11PPC MacOS10.5.5
Posts: 11

Rep: Reputation: 0
Quote:
Originally Posted by buzzybee73 View Post
Hey MotSteve....


Anyway, I tried what you said, and I got, and I got this..

Section "Device"
Identifier "Videocard0"
Driver "r128"
Option "UseFBDev" "true"
Try substituting fbdev for r128 in the above. All the documentation tells you to put r128, but it never works. Go figure. :-)

Also remember that if this works, to go to a terminal in the desktop environment and change the /etc/inittab default run level from 3 to 5, so that you'll automatically go into the gui and not into the terminal mode.
 
Old 10-09-2008, 02:33 PM   #12
buzzybee73
LQ Newbie
 
Registered: Nov 2006
Posts: 6

Rep: Reputation: 0
Question

Quote:
Originally Posted by motsteve View Post
Try substituting fbdev for r128 in the above. All the documentation tells you to put r128, but it never works. Go figure. :-)

Also remember that if this works, to go to a terminal in the desktop environment and change the /etc/inittab default run level from 3 to 5, so that you'll automatically go into the gui and not into the terminal mode.
Thanks for that, but I still have no idea how to change such a setting in text mode?

Can anyone tell me how to do this please??

Cheers,

Buzz
 
Old 10-10-2008, 06:17 AM   #13
motsteve
LQ Newbie
 
Registered: May 2008
Location: Plantation, FL
Distribution: Fedora 9 Suse11PPC MacOS10.5.5
Posts: 11

Rep: Reputation: 0
Quote:
Originally Posted by buzzybee73 View Post
Thanks for that, but I still have no idea how to change such a setting in text mode?

Can anyone tell me how to do this please??

Cheers,

Buzz

When you log in as root into Fedora and are in the terminal mode, you have to use a text editor such as vi or nano to edit the /etc/X11/xorg.conf file. There is not enough room here in the forum to give all the details on how to learn the basics of text editing, but there are many places on the web to help you. Just Google "linux text editor" and it shouldn't take very long to learn enough to accomplish this. Having this simple knowledge is crucial in using Linux effectively. I really mean this and I hope this doesn't just sound like I'm avoiding answering your question outright. Learning is fun to me, so maybe I am a little biased. :-)
 
Old 10-14-2008, 06:22 AM   #14
buzzybee73
LQ Newbie
 
Registered: Nov 2006
Posts: 6

Rep: Reputation: 0
Thanks everyone, worked it all out, now I have X Srever working fine, also had to work out how to change the time using terminal, before I did this, Bonobo server was giving me a right headache..

Cheers, Buzz
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Install Fedora 7 on PPC Mac Mini doza Linux - Newbie 1 10-22-2007 04:19 PM
Trying to install fedora 5 ppc on Mac Xserve jsniper Linux - Newbie 3 12-12-2006 11:08 AM
I can't install fedora 5 using GUI joeenet Linux - Software 5 05-17-2006 02:43 PM
fedora dvd install on ppc? bobotoes Linux - Newbie 0 10-18-2004 12:41 PM
YelloDog PPC: how not to boot into GUI? chrislee8 Linux - Distributions 2 08-04-2004 04:59 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora

All times are GMT -5. The time now is 01:34 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration