-   Fedora (
-   -   Fedora 8 won't start after fresh install (

Ab3n 11-28-2007 10:57 AM

Fedora 8 won't start after fresh install
Hey all,

I've installed Fedora 8 on my western digital usb external hard drive without a hitch, but when I try to boot from it for the first time after the install it always hangs during startup after it says this:


Reading all physical volumes.  This may take a while...
Found volume group "VolGroup00" using metadata type lvm2
2 logical volume(s) in volume group "VolGroup00" now active

It's not frozen as the keyboard is still responding, but even after a couple hours it is still at this screen. I've installed using two different live cd's and a dvd as well as several different computers, but the same thing happens every time...Any ideas?

inspiron_Droid 11-28-2007 12:34 PM

Didyou forget to install a boot loaderon the master boot record of the first Har Drive?
If so Please Reinstall and make sure you don't un chck the back on the load boot loder screen that saya place boot loader on the Master Bott Reacord of the MAIN harddrive on the first controler other waise know as HDA.

Ab3n 11-28-2007 12:55 PM

The bootloader is installed on the MBR...the external hd is the only hd installed too.

Ab3n 11-28-2007 03:22 PM

Has anyone been able to install fedora 8 to an external usb hard drive? If so did you do anything different from the default install? I've been able to do it with several other distros, just not fedora 8...

Ab3n 11-29-2007 07:04 PM

I installed fedora 7 on the drive just for grins and it works flawlessly. I then tried upgrading to fedora 8 via "yum upgrade" and the upgrade also went fine until I rebooted for the first time and chose the new fedora 8 kernel which hung at the same point...So I rebooted and chose the fedora 7 kernel and it boots just fine, but I still can't boot into the fedora 8 kernel. Any more suggestions?

v00d00101 11-29-2007 09:56 PM

Dont use LVM?

wmakowski 11-29-2007 10:54 PM

I'm not as certain that not using LVM is the answer, especially given the fact that Fedora 7 worked flawlessly. Not using LVM may infact resolve it, but perhaps this is an issue with the new kernel and should be reported as a bug. Did your F7 install use LVM?

One thing to try without going through a complete reinstall is to install the F7 kernel keeping the F8 system intact. This will also tell us if it is an issue with the F8 kernel. Some people may say this is goofy, but it worked for me when an F7 install would not boot, so I used the FC6 kernel and wallah, I was up and running.

If I remember correctly this is how I installed an older kernel on a non-bootable installation.
1) boot from rescue DVD/CD and use linux rescue at the prompt
2) pick language, keyboard, then it will ask if you want to find any fedora installations, click continue so it will mount it readwrite to /mnt/sysimage. If you have more than one Fedora installation on the drive make sure to pick your F8 install.
3) When you get to the shell prompt, chroot /mnt/sysimage
4) rpm -ivh --oldpackage (I made some assumptions here about your architecture i386 and system i686, change if necessary)

Note that this will not replace the current F8 kernel, just add another older kernel. kernel package processing works a little different than regular packages.


All times are GMT -5. The time now is 12:19 AM.