LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices


Reply
  Search this Thread
Old 02-11-2008, 11:37 AM   #1
Mr. Swillis
Member
 
Registered: Sep 2005
Location: The PNW
Distribution: Many. Slackware is the main reason I'm here though :)
Posts: 95

Rep: Reputation: 17
Fedora 8 Nvidia Issues


Hello,

I've been following fedora for a while now and just upgraded to Fedora 8. The word "upgrade" is kind of loose. It's really a fresh install, but I have a FAT partition where I back up my data first. I used the gnome live-cd to install (also did this back when I installed Fedora 7). Like usual, I hit fedorafaq.org to get all of my extras installed. I was successful with all of the browser plugins, codecs, etc, but ran into an error with kmod-nvidia.

Here's the error I get:
Code:
[root@localhost tmp]# yum -y -t install kmod-nvidia

Error: nvidia-x11-drv conflicts with xorg-x11-drv-nvidia
If I use rpm to query those two packages I get this:
Code:
[root@localhost tmp]# rpm -q nvidia-x11-drv
package nvidia-x11-drv is not installed
[root@localhost tmp]# rpm -q xorg-x11-drv-nvidia
package xorg-x11-drv-nvidia is not installed
Using the same installation method and the yum configuration from fedorafaq.org with Feodra 7, I didn't have this issue at all. Has anyone else run into this with Fedora 8?

Thanks!
 
Old 02-11-2008, 04:00 PM   #2
shafty023
Member
 
Registered: Oct 2007
Distribution: OSX
Posts: 248

Rep: Reputation: 31
Ya i had that issue.......hmmm what did I do to resolve that.
First, do this without quotes "rpm -q --all | grep nvidia-x11"
second, post here the output of "yum repolist"
 
Old 02-11-2008, 05:08 PM   #3
lazlow
Senior Member
 
Registered: Jan 2006
Posts: 4,363

Rep: Reputation: 172Reputation: 172
If you have not done your initial round of yum updates (without third party repos) do so. There were a few gotchas(there always are) that were straightened out in the first month.
 
Old 02-11-2008, 11:24 PM   #4
Mr. Swillis
Member
 
Registered: Sep 2005
Location: The PNW
Distribution: Many. Slackware is the main reason I'm here though :)
Posts: 95

Original Poster
Rep: Reputation: 17
Thanks for the tips. I had actually run "yum update" with the additional repos *before* trying to install kmod-nvidia when I received that error. Since it was such a recent installation, I just re-installed from scratch and was actually able to install the nvidia driver fine when I did it first. I'm assuming the error message I was receiving was probably due to a package I had unknowingly installed during that first big update.

Thanks!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
nvidia driver, twinview, xorg.conf issues on fedora 4-64 elpatan Fedora 2 01-24-2006 11:18 PM
nVIDIA Issues DaBlade Linux - Hardware 1 11-17-2005 01:53 PM
Nvidia 6800 Issues BlackJackal Mandriva 2 10-18-2005 01:25 AM
nVidia Kernel issues. smudge|lala Linux - Hardware 1 01-29-2005 12:05 PM
nvidia issues santasballz Linux - Newbie 1 03-14-2004 01:17 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora

All times are GMT -5. The time now is 08:03 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration