LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices


Reply
  Search this Thread
Old 01-15-2007, 12:49 PM   #1
DaveVT5
LQ Newbie
 
Registered: Dec 2005
Location: Blacksburg, VA
Distribution: Fedora Core 4
Posts: 12

Rep: Reputation: 0
Fedora 6 Install Lockup on "io scheduler cfq"


I am trying to install Fedora 6 (x86_64) on a new Dell AMD 64 X2. I'm not getting very far. It's hanging on "io scheduler cfq (registered)"

Any thoughts?
 
Old 01-23-2007, 04:00 AM   #2
kfife
LQ Newbie
 
Registered: Jan 2007
Posts: 2

Rep: Reputation: 0
I get the same problem booting from a usbflash drive. When I copy diskboot.img from the x86_64 iso, it fails at that message. When I copy diskboot.img from the i386 iso, everything works. Of course, I want to use the x86_64 iso. Did you figure out the problem?
 
Old 01-24-2007, 08:35 AM   #3
DaveVT5
LQ Newbie
 
Registered: Dec 2005
Location: Blacksburg, VA
Distribution: Fedora Core 4
Posts: 12

Original Poster
Rep: Reputation: 0
No, I never did figure it out. The problem is that I'm installing from the CDs so I wouldn't know how/where to copy the diskboot.img file.

I ultimately went with the i368 install which is unfortunate but I had to get the server up. If anyone knows the solution I will reinstall the 64 bit version.
 
Old 01-28-2007, 05:26 AM   #4
kfife
LQ Newbie
 
Registered: Jan 2007
Posts: 2

Rep: Reputation: 0
I updated the bios for the mobo I was using: Asus_M2NPV-VM. After the update, the FC6 install for x86_64 went smoothly.
 
Old 03-02-2007, 12:04 PM   #5
jfbp
LQ Newbie
 
Registered: Mar 2007
Posts: 1

Rep: Reputation: 0
Fix for io scheduler cfq hang

I too tried to install Fedora 6 (x86_64) on a new Dell AMD 64 X2, and got the "io scheduler cfq" hang.
I find the fix given at
deekayen -dot- net -slash- node -slash- 1058
(strange format to get round restriction on posting URLs)
for Fedora Core 5 also works on Fedora Core 6.
The fix is to use the following command line to boot when the bootdisk first loads:

linux noapic acpi=off nofb
 
Old 03-02-2007, 11:27 PM   #6
DaveVT5
LQ Newbie
 
Registered: Dec 2005
Location: Blacksburg, VA
Distribution: Fedora Core 4
Posts: 12

Original Poster
Rep: Reputation: 0
Thanks! I have the 32bit version installed now, but I'll give that a try at some point.
 
Old 03-04-2007, 01:11 PM   #7
velcroman
LQ Newbie
 
Registered: Mar 2007
Location: Sunderland, England
Distribution: Ubuntu Edgy + Puppy
Posts: 2

Rep: Reputation: 0
I had the same boot lockup problem on Ubuntu 6.10 (edgy) 64 bit.
I found various ways around it...
MSI K9NGM m/b (AMD64)
(1) Disable ACPI in BIOS - not very good because I want to monitor CPU etc.
(2) add "pci=noacpi" to the grub boot command - That works OK
(3) disable the IOAPIC function in BIOS - This is the method I am actually using. Everything seems to be OK.

One other problem... Soft reboots lock up during the startup. I need to switch off/on after running M$Windoze to get back to Linux.

Last edited by velcroman; 03-05-2007 at 04:30 PM.
 
Old 03-05-2007, 07:30 AM   #8
DaveVT5
LQ Newbie
 
Registered: Dec 2005
Location: Blacksburg, VA
Distribution: Fedora Core 4
Posts: 12

Original Poster
Rep: Reputation: 0
How do I make these changes when booting from a CD during install? Is there something I type before "net install" or whatever the command is to start Fedora startup?
 
Old 03-05-2007, 04:42 PM   #9
velcroman
LQ Newbie
 
Registered: Mar 2007
Location: Sunderland, England
Distribution: Ubuntu Edgy + Puppy
Posts: 2

Rep: Reputation: 0
DaveVT5, (sorry I am not familiar with the Fedora CD boot)

To use this parameter when booting from a CD try typing "pci=noacpi" if there is any point when you normally just 'hit return', or if there is a point when you get the choice to select 'other options' you can try then.

If you are booting from GRUB (boot loader) you can...
(1) type 'e' to edit the currently selected choice
(2) select the Kernel line and type 'e' (to edit it)
(3) type "pci=noacpi" {return}
(4) type 'b' to boot.

If you actually install Linux to your HD then you can to manually edit (sudo gedit) /boot/grub/menu.1st to add this parameter to the Kernel line to avoid doing (1-4) every time.
 
  


Reply

Tags
fedora, install


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora Core 2: Screen Resolution can not change from "800X600" to "1024X 768" suhaimi_sj Fedora - Installation 18 12-17-2009 03:29 AM
my linux is not booting and says "bug:soft lockup on cpu 01" amolgupta Linux - Software 1 12-13-2006 05:45 AM
LXer: CFQ to become the default I/O scheduler in 2.6.18 LXer Syndicated Linux News 0 08-16-2006 04:54 AM
FC1 job Scheduler problem - "at" command doesnt wrk linfreak Fedora 2 01-08-2006 03:12 AM
Can't install "glibmm" library. "configure" script can't find "sigc++-2.0&q kornerr Linux - General 4 05-10-2005 02:32 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora

All times are GMT -5. The time now is 07:41 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration