-   Fedora (
-   -   Fedora 4 no logon screen - blank screen with X (

yorgmeister 05-22-2006 07:05 PM

Fedora 4 no logon screen - blank screen with X
I was trying to install gnome-system-tools and the many dependancies it has. the last one I tried to install was pango apparently it installed, and then I rebooted becouse the rpm install windows would all of a sudden dissappear without saying weather or not anything was installed.
I havent been able to start my computer since. I only get to the blank screen with an x. Once and a while a text dialogue appears and says "The display server has been shut down about 6 times in the last 90 seconds, it is likely that something bad is going on. I will try again to restart the display server in 2 minutes.0"

What the hell happend???!!! nobody else seems to have this problem!!


macemoneta 05-23-2006 12:10 AM

Check /var/log/Xorg.0.log for errors.

yorgmeister 05-23-2006 02:48 AM

I did, and there was nothing that said error.

macemoneta 05-23-2006 10:21 AM

Post the file (in a quote block), and we'll take a look.

yorgmeister 05-23-2006 11:46 AM

Too late I could not wait for an answer anymore, I've re-installed. But Just in case this happens again what would cause this?

macemoneta 05-23-2006 11:54 AM

The nature of the error will be in /var/log/Xorg.0.log. An error doesn't always have the word 'error' in it.

yorgmeister 05-23-2006 02:16 PM

Thanks for your help I'll remember that the next time.

jackyowl 05-24-2006 09:17 PM

i also have almost the same problem.but my problem appear after i run fsck when os when i boot its shows thats some files missing.

when boot:

/etc/rc3.d/s56xinetd file missing


for your info,my linux is a file server with samba setting. now samba is available, only that i just cant get in the Xwindow...i use kde last time. i press Ctl+alt+f7 blank screen come out....

Help me, very urgent now

macemoneta 05-24-2006 09:49 PM

This should really be in a separate thread, since its a completely different problem.

You can identify the packages that you need to reload, by querying the rpm database for the missing files. For example,

rpm -qf /usr/lib/sa/sadc

This will tell you the package that contains the deleted file. You can download it, then force a reinstall:

rpm -Uvh --force xxx-y.x.rpm

jackyowl 05-25-2006 02:53 AM

i have follow your instruction and get some of this package

if i reinstall...would it effect to my comp samba server setting?

this what i get thats

file system-2.3.0-1

if i reinstall above package any effect?for your info i use fedora core 3

/dev/VolGroup00/LogVol00 as root

macemoneta 05-25-2006 11:07 AM

The effect is that your system will have integrity, it does not now.

Existing configuration files that have been customized should not be replaced. Rpms are configured to create an "xxx.conf.rpmnew" or "xxx.conf.rpmsave" file, if an existing configuration file is found.

jackyowl 05-26-2006 04:45 AM

ok...i have try the method..but stil can't success...i press alt+f7 the mouse not spinning,but can see the movement but stil appear in blank screen.

macemoneta 05-26-2006 10:13 AM

You will need to log off and restart X (ctl-alt-backspace), then check /var/log/Xorg.0.log for errors. Repeat the process if additional missing files are reported. If it continues on more than you are willing to put up with, then a re-install may be easier.

0mg 06-16-2006 04:06 PM

I have the same problem as yorgmeister. I am running Ubuntu 6.06, and i got it when i last update. When the login window is supposed to pop up my GDM crashes few times and the linux switches between terminal and GUI.
I dont know what couses this, but i believe that it starts to happen when i configure the "login window" and reboot.
I am posting you my Xorg.0.log file and i hope you will be able to help me without reinstalling my Ubuntu.

ht tp://

My graphic device is Ati Radeon 9550, CPU: AMD Semprom 2800+.

I hope this is enough.

10x for the help :)

macemoneta 06-16-2006 04:50 PM

Omg: the errors I see in your log are:

(EE) xf86OpenSerial: Cannot open device /dev/wacom

If that's your only mouse device, then X will not start until you get it working again (or configure a different mouse).

All times are GMT -5. The time now is 06:03 AM.