-   Fedora (
-   -   fedora 4 boot problem (

raft 04-27-2008 10:30 AM

fedora 4 boot problem

i have a dual boot fedora 4 laptop. it was working quite stable for more than 1.5 years. now i cant boot it. indeed it boots but i can not login

boot sequence first complains about missing font latercyrheb-sun16. most of the services start and a few fail. finally it ends up with a text based gui saying "the gdm user does not exist. please correct gdm configuration /etc/X11/gdm/gdm.conf and restart gdm"

i shifted to another console with CTRL+ALT+F1 and tried to login. i couldn't login either with my regular user or root account.

any ideas what may caused this and how to fix it ?

i have a bootable knoppix cd but it's a bit old and does not recognize my SATA drive. so i cant figure out what is going inside

one may ask what i did at my last successful login which my cause this. i was trying to install recordMyDesktop. it requires a decent version of glibc so i updated my glibc family (glibc, glibs-common etc) of RPM's to 8.1. i had installed a few more RPM's but not sure now what they were.

thanks in advance,
r a f t

lazlow 04-27-2008 11:30 AM

The version of glibc that the system is built around is pretty much integral to the system. While it is possible to add an updated version in parallel it sounds like you forced an upgrade. This probably broke your install. If you need the updated glibc you would be better off upgrading to a support version (F8 right now, plus F9 in a couple of weeks).

raft 04-27-2008 11:56 AM

i see :/ thanks for the answer and clarification.

so, is there a way turning back ? or should i somehow reach my files, backup them and make a fresh install ?

lazlow 04-27-2008 12:52 PM

You can turn back but it is a lot of work and you will always wonder if you got them all. Most of the rpms will contain a marker (FC4 or F8). You have to track them down and replace all the F8 ones with FC4 ones.

I would just back all your files up and do a fresh install of F8. Another thing to consider is that Fedora now only supports versions for about 1 year. It appears that you like to install and then just keep what you have. Centos is RHEL with the logos removed. It is free to download and has support for 5 years. The current (RHEL/Centos) version is 5.1. It was based on FC6 and "feels" very much like it. I use Centos on all my servers now, but still run F8 on my desktop.

raft 04-27-2008 02:07 PM

indeed it's all about my lazyness :) maybe it's time to take the opportunity and install ubuntu..

btw, fedora 4 hadnt recognized my video chipset so i downloaded and compiled X myself. i guess that may be the reason of it allowing me to upgrade glibc-xx without noticing dependencies.

seraphim172 05-04-2008 07:57 AM

yum -y upgrade
You should have upgraded release-by-release (Fedora 4 to Fedora 5, Fedora 5 to Fedora 6, etc). This can be done by using

yum -y upgrade
after having installed the appropriate yum repositories. It worked for me. Googling on this topic will give you enough info.

Upgrading from Fedora 4 to Fedora 8 is quite a big step. It could work, but I haven't tested that.

Linux Archive

All times are GMT -5. The time now is 03:20 PM.