-   Fedora (
-   -   Fedora 19 boots only in emergency mode after trying to replace Gnome with LXDE (

Neyzan 10-03-2013 10:00 AM

Fedora 19 boots only in emergency mode after trying to replace Gnome with LXDE
As Gnome 3 has become rather heavy in Fedora 19 for my Netbook I tried to replace in with LXDE via yum shell like this:

>yum remove @gnome-desktop
>ts list
>yum install @lxde-desktop
>ts list

Unfortunately ts list showed that with yum remove @gnome-desktop I would be removing every package I have, so instead I installed @lxde-desktop and removed only gnome-shell and its dependencies that yum listed. Package-cleanup didn't show me any problems but when I rebooted X crashed and since Fedora boots only in emergency mode.
I tried to solve the problem by inserting a USB stick with a live image of the LXDE spin of Fedora 19, setting it up as a repo following this method and reinstalling lXDE from there, but the only message I get is that yum can't connect to dbus. Note that in emergency mode I have no access to the internet wired or wireless.
Does anyone know how to solve this problem?

jpollard 10-03-2013 10:54 AM

You will need to use an install disk to reinstall the package group "Minimal Install"... I'm not sure, but it may also take a "Basic Desktop", but I don't think it will.

Some consider it easier to reinstall without installing Gnome. The problem is caused by gnome packages including required packages (part of the Minimal Install) that get removed when Gnome is removed.

It is usually easier to just install both Gnome and other desktops... Trying to remove gnome just seems to cause failures like yours. These don't seem to happen if gnome is never installed.

All times are GMT -5. The time now is 07:53 PM.