-   Fedora (
-   -   Fedora 17 - reinstalled NetworkManager, no icon, no nm-applet (

Flemur 11-02-2012 07:16 AM

Fedora 17 - reinstalled NetworkManager, no icon, no nm-applet
I've been chasing this for a couple of days w/o any luck.

Trying to speed up boot/fooling around, I:
- uninstalled "NetworkManager" and
- installed wicd, which worked fine but was actually considerably slower (FWIW, on Mint "network-manager" hangs at shutdown and causes other problems, and wicd doesn't).

Then I
- uninstalled wicd and re-installed NetworkManager.

The network works but there's no icon; there's also no "nm-applet" program on the machine.

Searching for nm-applet in yumex -> "NetworkManager-gtk" (installed package), but there's no file called "NetworkManager-gtk" on the machine and no indication about what suppsedly shows the icon. There's no "nm-applet" package to install. The "Notification Area" is working fine and shows the audio volume icon.
Edit: there're also no files that look anything like "network-manager-applet", apparently another name for "nm-applet".

Q How can I get the network icon back using NetworkManager?

Edit: I tried installing an nm-applet from source and discovered that: "yum" is slow and pretty bad, and "yumex" is rather user-hostile, reeeeaally slow, and hangs quite often - pure junk, which is very unfortunate for an important piece of software - so I'm going to mark this "solved" - by sticking with Mint.

TabletGuy 12-07-2012 02:28 PM

FYI: I believe the nm-applet is in the Fedora NetworkManager-gnome rpm. I too removed NetworkManager and tried to use wicd. In my case wicd experienced an unknown internal error and wouldn't allow the necessary userid and password info to be stored so as to connect to a WPA2 secured network. Trying to go back to NetworkManager (which keeps dropping the connection at random) has been frustrating.

I'm at the point now that everything except nm-applet starts. I created a button on my toolbar to launch it. Not ideal but nothing else will get it to start.

All times are GMT -5. The time now is 12:30 PM.