-   Fedora (
-   -   fedora 17 livecd boot problem:can't mount root file system bad superblock (

winhater 01-21-2013 05:40 PM

fedora 17 livecd boot problem:can't mount root file system bad superblock

I know, I'm not the first who's asking this question,but I haven't found reasonable answer yet
after intensive googling.

Recently by some accidental reason my Fedora 15 installation was completely removed
and I tried to install Fedora 17 in place of F15.
I downloaded Fedora's Fedora-17-i686-Live-Desktop.iso from and
burned CD.
Checksums verifications after downloading and burning CD both were OK.

But I could not even start loading vmlinuz0 kernel.

After some google search I edited slightly the line in grub.conf while booting in the following way:
I removed "quiet rhgb" for verbosity,
added "text" (without quotes) after initrd0.img to see what's happening
and change the initial fragment "root=live:UUID..." to "root=live:/dev/sr0"
(without quotes :-)

The result was that kernel loading started, but finally I got the following message:

"bad fs,bad option.bad superblock on /dev/mapper/live-rm dracut Warning: Can/t mount root filesystem Dropping to debug shell"

What's going on with Fedora?
I've been using Fedora since F9 which I installed from liveCD without problems
and since then successfully doing the upgrade thru preupgrade utility.

May be it's time to turn to Ubuntu? I wouldn't like to do this.
Finally, I've got accustomed to Fedora :-)

Could anyone give me a hint or point to the solution?
I really haven't found the answer.


82G33 IntelDualCPU
1.5G RAM
HD1 with Windows 2003 Server+CentOS 5.9 (it's mbr contains grub legacy loader)
HD2 with FreeBSD8.3 + empty place previously containing F15

BTW. The same or alike problem with F15&F16 liveCD

Air-Global 01-22-2013 11:23 AM

A bad superblock seems to be a 'damaged' cd. Maybe somewhere during the burning process.

And yes, it happens from time to time that a kernel or system mount is tagged wrong. But this seems to be system dependend, ive had the issue with all sorts of distro's on multiple systems. On one system the Live CD would load without issue, on an other it would not load because of a badly tagged file system, with the same cd!

Regarding Ubuntu, in my oppinion that Distro is dying. They are going way to wide on focus and are missing some of the crucial parts.

winhater 01-22-2013 04:42 PM

Thanks for your reply.
But your reply was not consolatory :-)
But, as I wrote, sha256checksum was correct AFTER downloading the ISO,
and, while burning CD I set the verification flag (in Nero) and Nero reported no burning errors occurred. The same problem when booting from CD burned in FreeBSD cdrecord utility.

And judging by what I've read in Inet, many-many people encountered the same problem with booting from liveCD for F15, F16 and F17.
Too many problems with Fedora, yeah?

So, which workable and functional alternative to Fedora would you suggest?
In fact, in Fedora 15 I could do whatever I need (Java/C++/php development, maplayer and so on :-)

Basher52 01-22-2013 08:57 PM

Sorry to NOT help, but I've never seen anyone with this problem :( (also not looking for it, but I haven't even heard of it in my network of friends)

Also sorry to hear this. I've used Fedora well, since before Fedora even existed, since Red Hat 7, then a small "hold" until Red Hat 9 came then every release since.
so, RedHat7, RedHat9, FedoraCoreX and now Fedora1-17 (Haven't installed F18 yet :P)

My first problem started with F17 due to BIOS and UEFI stuff. Other then that nothing, not one problem with F15 or F16, unless you think of the things I didn't do correctly or such but that's just on me :p
Used F15,F16 LiveCD on 3 different PCs(hardware) to try them out before installing it and no problem at all.

Hope you get your problems solved.
and if you do, if not from here, please do let us all know.
I sure am curious to what it can be.

All times are GMT -5. The time now is 04:01 PM.