-   Fedora (
-   -   fedora 16 live usb fails on boot with "cant mount root filesystem" (

ikarus 06-03-2012 11:03 AM

fedora 16 live usb fails on boot with "cant mount root filesystem"
The title pretty much says it all. Having persisted most of today and finally producing a live Fedora 16 USB stick with persistence - it actually worked - once. While it worked it was excellent!

After I powered it down and tried to use it again on two different machines I now get the message

cant mount root filesystem
and just prior to that

cant read superblock
. Then it bails out to a rather primitive command line prompt.

Does anybody know if it possible to rescue it from this state?


Didier Spaier 06-03-2012 01:22 PM

My guess is that you didn't identify your root partiton in /etc/fstab by UUID and thus the kernel can't find it.

I explained that in this post, steps 10. and 11.

EDIT To rescue it I would launch another system (either on HDD or live DVD, whatever), plug in the USB stick, check how it is named by the kernel ("dmesg|tail" after plug it in should tell you that), mount it e.g. as /mnt, then proceed to steps 10 and 11 as indicated above.

syg00 06-03-2012 08:35 PM

Sorry - didn't read the subject properly - post removed.

ikarus 06-03-2012 10:24 PM

thanks Didier - I'll give that a try and then report back.

ikarus 06-04-2012 11:39 AM

Sorry Didier - there seems to be a misunderstanding. My usb stick is a "live" iso image with an overlay file for persistance. When I mount the drive I do not see /etc or any of the usual directories, just "LiveOS" which contains squashfs.img.

Am I completely missing the point here?


All times are GMT -5. The time now is 04:16 PM.