-   Fedora (
-   -   Fedora 16 kernel panic pcie_aspm_init (

GATTACA 03-28-2012 02:06 PM

Fedora 16 kernel panic pcie_aspm_init
I ran into this problem after a kernel upgrade.
I finally solved it and wanted to post how I did it in case anyone else is having this wonderful experience.

After I upgraded the kernel to 3.3.0-4. I got this error message:

kernel panic not syncing attempted to kill init

I figured out the error had to do with the pcie_aspm_init line above.

After some googling, I edited the /etc/default/grub file so that the GRUB_CMDLINE_LINUX contained this at the end: pcie_aspm=force

Then I re-created the grub.cfg file with this command:

grub2-mkconfig -o /boot/grub2/grub.cfg
After that I rebooted and I was able to boot into Fedora 16.

My hardware is:
Intel DP67BG motherboard
Intel Intel Core i7-2600K

I hope this is helpful.

Lazy Fox 05-05-2012 05:34 PM

I ran the Software update tool and now there is a new entry for the 3.3.4 kernel in the boot menu. However, when I try to boot that there is "kernel panic". I noticed that there is no initramfs-3.3.4-1.fc16.i686.img in /boot (only an initramfs-3.1.0-7.fc16.i686.img)

Also for the old kernel there is a line

initrd /initramfs-3.1.0-7.fc16.i686.img

in /boot/grub2/grub.cfg

but this line is missing for kernel 3.3.4. How can I solve this problem?

"Asking questions makes you wise", my old neighbor always said. He never asked a thing.

GATTACA 05-06-2012 08:59 PM

I would reboot into the earlier working kernel (3.1.0-7) and then use that kernel to run yum update again to see if the update works this time.

Your problem doesn't seem related to my original post but I'm sure a little googling will help you out.
Maybe using dracut?

Lazy Fox 05-07-2012 10:30 AM

Thanks, yum upgrade solved the problem.

All times are GMT -5. The time now is 08:27 AM.