-   Fedora (
-   -   Fedora 14: "Can't Mount Root File System" Error (

OrangeOats 09-03-2011 11:29 AM

Fedora 14: "Can't Mount Root File System" Error

Fedora 14 has worked fine for me since I installed it many months ago but now I get this error message instead.

Thank you,


OrangeOats 09-03-2011 11:37 AM

Hello this is OrangeOats again. If it helps I also get the message:

mount: wrong fs type, bad option, bad superblock on /dev/mapper/name_root, missing codepage or helper program, or other error

smallpond 09-03-2011 02:17 PM

Is this system dual boot with Windows? Did you boot from any other media recently? It sounds like your disk got overwritten by something. Try making and booting from a rescue disk and read the partition table, but sit on your hands and don't make changes unless you're sure you know what's going on. Post back in this thread if you have questions. If you just let Fedora partition your disk when you installed then it should look pretty much like mine:


fdisk -l /dev/sda

Disk /dev/sda: 320.1 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders, total 625142448 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x000ab952

  Device Boot      Start        End      Blocks  Id  System
/dev/sda1  *        2048    1026047      512000  83  Linux
/dev/sda2        1026048  410626047  204800000  83  Linux
/dev/sda3      410626048  414722047    2048000  82  Linux swap / Solaris

The small first partition is /boot, the last 1G is the swap space, and the rest is the root volume.

OrangeOats 09-03-2011 03:45 PM

Thanks for your response.

I partitioned a hard drive on a laptop in which windows crashed such that some of the windows files were still there. It's a total mess after I had an accident with gpart while trying to resize the partitions many months ago but this is what the Fedora live cd sees (note the multi was the name of the parition/drive I used Fedora on:
LVM Volume Groups

VolGroup 124928:
lv_root 51200 Unknown
Free 73728

vg_multi 78976:
lv_root 38208 ext4
lv_home 34912 ext4
lv_swap 5856 swap

Hard Drives

sda1 10018 ntfs
sda2 23240 ntfs
Free 251
sda3 502 ext4
sda4 204462 Extended:

sda7 0 Unknown
sda6 0 Unknown
sda8 500 ext4
sda9 124950 VolGroup physical volume (LVM)
sda5 79002 vg_multi physical volume (LVM)

I selected install fedora to get to this screeen from which I exit. I beleive it only sees the 500 size on which to install. When I tried the upgrade to the same operating system or Fedora 15 I get an unhandled exception. When I try to do a rescue with the cd it says no useable disks have been found.

Thank you,

Orange Oats

smallpond 09-05-2011 07:00 AM

Your best bet is to boot from a live CD like Knoppix and try to mount the partitions, then retrieve and back up any information that you need. No idea whether the existing partitions can be saved, but anything you try has a chance of making it worse. Last I checked resizing a partition with LVMs did bad things in parted; maybe that's been fixed.

OrangeOats 09-06-2011 09:30 AM

Thanks, I'll try that.

All times are GMT -5. The time now is 09:14 PM.