LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Fedora (https://www.linuxquestions.org/questions/fedora-35/)
-   -   FC8 hp pavilion dv4 no sound (https://www.linuxquestions.org/questions/fedora-35/fc8-hp-pavilion-dv4-no-sound-697364/)

rsashok 01-14-2009 06:50 PM

FC8 hp pavilion dv4 no sound
 
I installed FC8 on HP Pavilion dv4. There is no sound coming out of speakers at all. It detects the right sound card: Intel 82801 (ICH9 Family) HD Audio Controller, but 'Play' button in 'Sound test' window does not produce a squeak!

I tried many things suggested on the web, including downloading and compiling hew ALSA driver, but to no avail.

Could anybody give a guide how to restore the sound.

jschiwal 01-14-2009 07:36 PM

A) Check if sound is muted
B) Run both alsaconf and your systems sound configuration wizard.
Sometimes running one and not the other isn't successful. Alsa starts out muted after updating. Run alsa config after building a new alsa driver.
C) Make sure you are a member of the Audio group.
D) Check that the alsa kernel module is loaded
E) If you compiled a new alsa module, you may need to reboot, or at least unload alsa and reload it. If it is in use, rebooting is a better idea to prevent a lockup. ( The filesystem won't delete the inode of an old file if a process has the file open. So you could update the alsa driver, but the kernel could still be using the old one, even if the old one doesn't show up in a directory entry.

rsashok 01-14-2009 10:58 PM

lsmod | grep -i alsa
doesn't show any 'alsa' related modules. Is this a problem? If it is, how do I install this module?

lsmod | grep -i snd
shows quiet a few 'snd-' modules.

BTW: I ran System->Preferences->Hardware->VolumeControl to make sure that sound is unmuted. But little LED icon on the laptop is orange, which indicates sound is muted, I guess.

John VV 01-15-2009 01:34 AM

fedora 8 had a bunch of problems with the , at the time,VERY new pulse audio .This was fixed in fedora 9 an 10

fedora 8 is passed it end of life and is no longer supported .
but if you insist on using a unsupported version of fedora you could remove pulse audio
some OLD links about pulse audio
http://www.pulseaudio.org/wiki/PerfectSetup
http://forums.fedoraforum.org/showth...217#post938217

edwinboersma 01-15-2009 02:15 AM

Add a line "options snd-hda-intel model=laptop" to /etc/modprobe.d/sound (or whatever file is used). This fixed it for me.


All times are GMT -5. The time now is 12:29 AM.