-   Fedora (
-   -   FC7 rescue from USB 1.1 dvd - -problems (

stillwaters 10-20-2007 11:27 AM

FC7 rescue from USB 1.1 dvd - -problems
I am trying to install Fedora 7 on an old laptop (IBM Thinkpad 770Z) using an external USB device.

I would like to understand what must be done to allow FC7 rescue kernels to find USB 1.x devices the way FC3 used to.

My 770Z is a 1999 (or so) vintage model, and can not natively boot from external USB devices, and… worse, the internal DVD does not boot DVD’s (The system dual boots XP and it reads / plays DVD’s fine; it boots CD’s too so I’m pretty sure it’s just old firmware. I have the latest firmware from the IBM / Lenovo support web site. (Firmware is from 1999!!) It has been running FC3 for years, but now I want to add new SW that requires a more recent kernel. Additionally I’ve lost track of the file systems and there is too much “bloat,” so I really want to do a fresh install.

Lastly… I just reinstalled FC3 on this laptop yesterday, so I know all hardware is healthy and that FC3 finds / installs from the external DVD.

I tried using the FC7 rescue disk but apparently FC4 and beyond no longer support USB1.X (??) from the rescue kernel.

Can someone help me understand what happens “underneath the covers” of an install?
I have tried many combinations of FC3, FC6, and FC7…rescue cd’s. I have also completed the FC7 install on a newer Dell, so I know all disks are good.

I tried :
-booting FC7 rescue,
-did a chroot /mnt/sysimage, then
-a modprobe to load the FC3 usb_storage module, hoping to mount the external USB DVD and attempt to trick the ramdisk kernel to allow an install, but my knowledge falls short.
- - - modprobe fails -conflicts with FC7 ramdisk directory name modules and installed FC3 kernel modules
( I believe the FC7 (…actually FC4 and beyond) dropped some of the host controller support (UHCI??)

So a basic question is: if I boot with rescue FC7, can someone tell me how to:
1) manually enable support for usb1.0 && 1.1 from the ramdisk image,
2) start the install from the newly mounted FC7 dvd?
3) Nice to have would be a pointer to a better understanding of loading kernel modules,
4) Maybe even building a boot image for future installs?

Or could it be as easy as adding kernel boot time commands from the rescue boot?

Thanks in Advance!!

Brian1 10-20-2007 12:26 PM

From my knowledge you would need to make a boot floppy or cd and then it could boot the USB since USB is not an option on that model from what I remember when I owned one years ago. There is a better doc somewhere but eludes me. I did find this about making a boot floppy to boot usb drive.


stillwaters 10-20-2007 12:32 PM

FC7 USB DVD problems
Brian, Thanks. Unfortunately I have no floppy on this system.
Just to be clear, all works fine at FC3,(Rescue boots, see's DVD...) it's just that FC7 rescue no longer see's any external USB device.

Brian1 10-20-2007 12:45 PM

post the steps and commands you do to do this for FC3.

My guess maybe the rescue kernel does not have either ohci-hcd and or uhci-hcd in the kernel. This is the modules for 1.0-1.1 usb controllers.


stillwaters 10-21-2007 09:18 PM

I agree; the FC7 boot cd / rescue kernel has only uhci_hcd. (I just booted FC7 rescue CD, got a shell, then ran lsmod.)

As far as the steps with FC3 - I boot the rescue CD in the internal CD with the FC3 dvd in the external dvd and it installs fine.

So I believe I need to create an initrd image that has ohci_hcd and ehci_hcd, and maybe usb_storage on my own version of FC7 rescue disk.
It seems fairly simple - I plan to follow some of the steps in the following links.

...unless someone knows how to install the FC7 dvd when booting from the FC3cd ??

stillwaters 10-21-2007 11:46 PM

I'm trying to understand how to force the usb1.1 driver
Hmmm Now I'm _Really_ confused.

I was able to extract the initrd image from the FC7 rescue cd, and it turns out to be a cpio image.

I transferred it to a temp directory and can see to boot directory structure.

As I looked through the directory, I see there is a modules "directory"
It's another compressed cpio image.
I executed a gzip -dc modules.cgz | cpio -itv and I can see that uhci-hcd.ko ehci-hcd and ohci-hcd kernel modules are there.

I have a system sitting at the shell prompt in the FC7 rescue disk.
I tried a modprobe ohci-hcd and ohci_hcd and ohci-hcd.ko ...
all report "modeprobe: could not parse modules.dep"

I'm speculating there is something that controls the loading of these modules, linked to the modules.dep text file.

Can anyone pass me a clue from the clue bag??
In other words, it appears thes are in / on the FC7 rescue CD, they're just not loaded. Can anyone tell me how to force them ?

stillwaters 10-22-2007 12:59 PM

boot fc7 rescue CD to install from external USB dvd
I think my problem is solved...
After booting FC3 and FC7 rescue disks and validating load modules, scrutinizing dmesg, etc, it seems FC7 told me what was wrong all along!

Dmesg reported some problems with an interrupt (int 10) and produced a lot of information about PCI, USB, and Scsi devices, then suggested I boot with irqpoll.

So I did; I booted the FC7 rescue disk... escaped the graphics boot, and typed "linux irqpoll" at the boot prompt, had my USB DVD with the FC7 DVD in it, and my dvd was detected and I'm installing.

It appears the irq conflict obscured the presence of my USB DVD and the boot kernel simply didn't load the usb_storage module.

At this point, I do not know why I had a conflict, and I do not care too much, as I'm now good to go.

A simple extension of RTFM applies: RTFSL (read the system logs!) the information simply scrolled past too fast and I ignored it.

Updates upon success / failure later today.

wmakowski 10-22-2007 04:11 PM

Received your email, but it looks like I'm too late. It's a good feeling to solve things yourself. There were a number of changes in the way the F7 kernel handles devices. This is what caused me some grief during my F7 install. Ended up building my own boot disk and filing a bug report. The latest kernel seems to have solved the problem I was having. Perhaps these device changes are ultimately what caused your issue as well. Bet you can't wait to install F8 in about a month or so. 8-)


Brian1 10-23-2007 04:35 PM

Glad to see you have it going. Would have never thought of preceding the way you went or at least without being at the machine anyway.


All times are GMT -5. The time now is 11:14 AM.