-   Fedora (
-   -   fc6xen kernel panic after yum update (

yowzator 05-13-2007 05:32 PM

fc6xen kernel panic after yum update

I used yum update on a newly installed FC6 system a couple days ago. My system was updated from Fedora Core 2.6.18-1.2798.fc6xen to 2.6.20-1.2948.fc6xen. The update went fine. After reboot, I got the following kernel panic:


Scanning logical volumes
  Reading all physical volumes. This may take a while...
  No volume groups found
Activating logical volumnes
  Volume group "vg0" not found
Creating root device.
Mounting root filesystem.
mount: could not fine filesystem '/dev/root'
Setting up other filesystems
Setting up new root fs
setuproot: moving /dev failed: No such file or directory
no fstab.sys, mounting internal defaults
setuproot: error mounting /proc failed: No such file or directory
setuproot: error mounting /sys failed: No such file or directory
Switching to new root and running init.
unmounting old /dev
unmounting old /proc
unmounting old /sys
switchroot: mount failed: No such file or directory
Kernel panic - not syncing: Attempted to kill init!

If I'd boot into the original kernel, it booted just fine.

So, today I took a spare system and installed FC6 fresh from installation disks. The very first thing I did after the installation was completed was do a yum update. After reboot, the exact same problem. Both systems don't work with the latest XEN kernel.

For reference, the only packages installed from the graphical installer were these:



Applications/Text-based Internet:

Base System/Base:
Base System/Virtualization:

Since the errors indicate LVM problems, here's info about my disk layout. I'm configured using two 72GB scsi disks using raid1, then lvm on top. Disk partitioning:


/dev/sda (72GB)
        /dev/sda1 (102MB)
        /dev/sda2 (69.9GB)
/dev/sdb (72GB)
        /dev/sdb1 (102MB)
        /dev/sdb2 (69.9GB)

/dev/sda1 & /dev/sdb1 are mirrored to /dev/md0
        used by /boot partition (102MB)

/dev/sda2 & /dev/sdb2 are mirrored to physical volume /dev/md1
        used in VolGroup00

/dev/md1 is LVM VolGroup00 and contains these logical volumes
        /dev/VolGroup00/lvdom0 (root)                3GB
        /dev/VolGroup00/lvswap0 (swap)                4GB

The rest of the space was left empty for xen guest partitions.

I've edited grub.conf to use /dev/mapper vs /dev/VolGroup00, but nothing has booted with the new kernel.

Is there a problem with the new kernel? Where should I go for a solution? Should I just run the old kernel for now? If I'm not in the best forum for this, where should I go for help?

Any help would be appreciated!


nomb 05-17-2007 09:44 AM

I'm not quite sure on how to fix the problems with the new xen kernel. However how I see it is you have two options.

1. Install the new non-xen kernel, see if that works and if it does and you want to be running the most updated kernel the forget xen and use virtualbox or vmware.


2. You can run the old kernel and just stop updating.


Yentor 05-19-2007 03:01 AM

yesterday i've reintalled my system, because i've intalled xen, and when i'll try to update it crashes, i don't have other choice i reinstalled, my datas lost. i make two partition to save the data, when crashes.

JeffSilverman 05-20-2007 12:54 AM

Installing Xen crashes my machine as well
I think I have the same syndrome. However, I tried to recover using the RedHat Fedora Core 6 rescue CD and little joy there, either. It says that there are no linux partitions.

The Rescue CD is wrong. Once I drop into the command line, I can run fdisk and I clearly see a boot partition, a swap partition, and a partition for everything else. The boot process starts. I can mount the everything else partition and copy information on to a USB thunb drive.

I tried modifying the /boot/grub/grub.conf file to try booting a non-Xen kernel with root=/dev/sda3 but that did not make a difference.

I'd really rather not install from scratch if I can help it. I have the data backed up and I think I have all of the configuration files in /etc backed up, but I would rather rescue the system if I can.

How does the rescue CD recognize a Linux partition if not by examining the partition table? If I have to reinstall, then would it be better to just have a single partition for files and a swap partition?

Many thanks,

Jeff Silverman
jeffsilverm at gmail dot c0m 05-20-2007 09:16 PM

LOL Yeah I am not too familiar with the xen kernel, but if I got that from another kernel bootup I would bet it was a problem with the initrd image, it sounds like it is missing altogether

All times are GMT -5. The time now is 08:16 AM.